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Course Description 

Course 202 – Civil 3D Fundamentals – ll is the second part in the three-part Civil 3D Fundamentals learning 

path. This course continues developing knowledge of Civil 3D features and functionality. Upon completion, 

a better understanding of Corridors, Cross Sections, Pipe Networks, Project Explorer, and Volumes and 

Materials will be achieved. 

Civil 3D Fundamentals courses 201, 202 and 203 have been developed to provide the basic functionality 

of the software to those who have had limited or no exposure to the Autodesk Civil 3D software. These 

three (3) courses deliver the building blocks to become more knowledgeable and proficient utilizing  

Civil 3D. 

Course Length 
8 hours 

User Guide Notification Icons 
This User Guide contains icons to help alert and assist the user with specific tasks and content. Each icon 

is identified and described in the table below. 

 

ICON DESCRIPTION 

 The EXERCISE icon identifies tasks where users are guided through a hands-on review of 

the instructional topic using the software.  

 
The TIP icon identifies software best practices and useful tips. 

 The NOTE icon is used for identifying general information such as: 

• To provide additional information that is not considered to be a warning or critical. 

• To provide additional/alternative steps to workflow. 

• To provide reminders of important information previously covered that may affect 

specific tasks throughout the workflow process. 

 The CAUTION icon is used to help identify and warn users of information and or workflow 

steps that should be followed or executed correctly. 
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Course Objectives 

• How to model Corridors 

• How to create Cross Sections 

• How to create and edit Pipe Networks 

o Pipe and Structure Catalogs and Parts Lists 

o Applying Pipe and Structure rules to Pipe Networks 

o Profile and Section display options 

• Compute Volumes and Materials for a project. Quantity Takeoffs (QTO) 

• Understanding and utilizing Project Explorer 

• Migrating legacy project data to Autodesk 

Topics Covered 

• Introduction to Corridors 

o Assemblies and Subassemblies 

o Corridor Frequency of Stationing 

o Corridor Targets and Target Types 

o Understanding and Using Regions 

o Corridor Surfaces 

o Cross Section Editor 

• Cross Sections 

o Generating Sample Lines 

o Single/Multiple Cross Sections 

o Section Views 

o Labeling 

o Utilizing the Cross Section Editor 

• Pipe Networks 

o Creating Pipe Networks 

o Pipe and Structure Catalogs 

o Pipe and Structure rules 

o Splitting, merging, reconnecting, and renaming Pipe Networks 

o Display options for Pipe Networks 

o Connection and insertion points 

o Generating tables and reports 
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• Project Explorer 

o Project data navigation, review, and editing 

o Evaluating design criteria 

o Generating tables and reports 

• Quantity Takeoff (QTO) 

o Earthwork Volumes 

o Material Volumes 

o Generating reports 

Pre-requisites 

• A basic understanding of design/drafting procedures and terminology 

• A working knowledge of your operating system  

• 101 – AutoCAD Fundamentals for Bentley Users 

• 201 – Civil 3D Fundamentals – l 



202 – Civil 3D Fundamentals – ll User Guide 

 

 

4 MDT Internal Use Only 

Table of Contents 

Course Description ..................................................................................................................................... 2 

Course Length ............................................................................................................................................. 2 

User Guide Notification Icons .................................................................................................................... 2 

Course Objectives ....................................................................................................................................... 3 

Topics Covered ........................................................................................................................................... 3 

Pre-requisites .............................................................................................................................................. 4 

Introduction to Corridors ........................................................................................................................... 7 

Design File Creation and Set-up ............................................................................................................ 8 

Create a New Drawing .......................................................................................................................... 8 
Attach External Reference Drawing ...................................................................................................... 9 
Create Data References...................................................................................................................... 10 
Create Surface Profile and  Display Design Profile ............................................................................ 12 

Assemblies and Subassemblies.......................................................................................................... 14 

Creating an Assembly ......................................................................................................................... 15 
Mirroring Subassemblies ..................................................................................................................... 16 
Organizing Subassemblies.................................................................................................................. 17 
Naming an Assembly .......................................................................................................................... 18 
Leveraging an MDT Assembly for corridor design .............................................................................. 21 
Create a Corridor ................................................................................................................................. 24 

Corridor Frequency ............................................................................................................................... 25 

Adjusting Corridor Frequencies ........................................................................................................... 26 
Solving Event Viewer Errors ............................................................................................................... 30 
Corridor Targets and Target Types ..................................................................................................... 31 

Understanding and Using Regions ..................................................................................................... 34 

Creating Corridor Regions................................................................................................................... 34 

Corridor Surfaces .................................................................................................................................. 36 

Create a Corridor Surface ................................................................................................................... 36 

Corridor Boundaries ............................................................................................................................. 39 

Create a Corridor Surface Boundary ................................................................................................... 40 

Corridor Section Editor ........................................................................................................................ 40 

Section Editor Overview and User Interface ....................................................................................... 40 
Using the Corridor Section Editor ........................................................................................................ 42 

Cross Sections .......................................................................................................................................... 45 

Sample Lines ......................................................................................................................................... 45 

Create a Section drawing .................................................................................................................... 45 
Sharing Data between Drawing Files .................................................................................................. 47 



User Guide Table of Contents 

 

 

MDT Internal Use Only 5 

Generating Sample Lines .................................................................................................................... 49 

Section Views ........................................................................................................................................ 52 

Create Section Views .......................................................................................................................... 52 

Section View Labeling .......................................................................................................................... 55 

Create Section View Labels ................................................................................................................ 55 

Earthwork and Materials ........................................................................................................................... 59 

Earthwork Volumes ............................................................................................................................... 59 

Corridor Surface Volumes ................................................................................................................... 59 

Material Volumes ................................................................................................................................... 62 

Creating a Materials List...................................................................................................................... 62 

Generating Volume Reports and Table ............................................................................................... 64 

Generating Volume Reports ................................................................................................................ 64 
Creating Volume Tables ...................................................................................................................... 66 
Creating Material Tables ..................................................................................................................... 68 

Pipe Networks ........................................................................................................................................... 69 

Part Catalogs and Part List .................................................................................................................. 69 

Create a culvert drawing ..................................................................................................................... 69 
Preparing the drawing for Pipe Network Objects ................................................................................ 71 

Pipe and Structure Rules ..................................................................................................................... 73 

Exploring Pipe Rules ........................................................................................................................... 73 

Creating Pipe Networks ........................................................................................................................ 74 

Referencing Existing Culverts ............................................................................................................. 74 
Pipe Network from Object ................................................................................................................... 75 
Extending Existing Culverts................................................................................................................. 76 

Editing Pipe Networks .......................................................................................................................... 80 

Splitting Pipe Networks ........................................................................................................................ 80 

Creating a Proposed and Existing Network ........................................................................................ 80 

Merging Pipe Networks ........................................................................................................................ 82 

Creating a single Pipe Network from multiple ..................................................................................... 82 

Disconnecting and Reconnecting Pipe Networks ............................................................................. 85 

How to Disconnect and Reconnect Networks ..................................................................................... 85 

Renaming Pipe Networks ..................................................................................................................... 86 

Editing network parts names ............................................................................................................... 86 

Display Pipe Networks .......................................................................................................................... 87 

Drawing Network Parts in Profile views .............................................................................................. 87 
Editing Network Parts Profile View Display ......................................................................................... 89 



202 – Civil 3D Fundamentals – ll User Guide 

 

 

6 MDT Internal Use Only 

Generating Labels, Tables and Reports ............................................................................................. 91 

Labeling Pipe Network Parts ............................................................................................................... 91 
Creating a Pipe Network Table ........................................................................................................... 93 
Producing Pipe Network Reports ........................................................................................................ 94 

Project Explorer ........................................................................................................................................ 95 

User Interface (UI) and Navigation ...................................................................................................... 95 

Project Explorer Window ..................................................................................................................... 95 
Preferences and Layout Options ......................................................................................................... 97 

Reviewing and Editing Object Data ..................................................................................................... 98 

Reviewing Object Data ........................................................................................................................ 98 
Editing Object Data ........................................................................................................................... 101 

Generating Tables and Reports ......................................................................................................... 103 

Tables and Reports ........................................................................................................................... 103 
Quick vs. Object Sets ........................................................................................................................ 103 
Tables using Quick Report ................................................................................................................ 103 
Tables using Object Sets .................................................................................................................. 105 
Reports using Object Sets................................................................................................................. 110 

 



User Guide Introduction to Corridors 

 

 

MDT Internal Use Only 7 

Introduction to Corridors 

You can use Autodesk Civil 3D corridor modeling to create flexible and configurable 3D models of corridors, 

such as roads, highways, ditches, and channels. A corridor model builds on and uses various Autodesk 

Civil 3D objects and data, including assemblies, subassemblies, surfaces, feature lines, alignments, and 

profiles. The corridor manages the data, tying various assemblies (applied for different ranges of stations) 

to the baselines and their finished grade profiles. 
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Design File Creation and Set-up 

Design files are drawing files used for specific design elements related to the project design. Such as, 

surfaces, alignments, corridors, etc. The following steps will walk us through the creation and set-up of the 

Corridor Design drawing file which must be done prior to creating corridor assemblies and the corridor itself. 

Create a New Drawing  

Step 1: From the Start tab > Create a new drawing using the Standard: design-start.dwt 

• C:\MDOH\StateKit\Civil 3D\2022\Templates\_Start-Dwg 

Step 2: Save and Name the drawing: 8684000RDCORD001-USER INITIALS.dwg 

• C:\mdtapps\Autodesk_Training\202-C3D Fundamentals-ll\Working  

Step 3: Navigate to the Manage tab > Styles panel > Select Reference  

Step 4: Verify the attached design-group reference template is loaded. 

Step 5: Click OK.  

Step 6: Navigate to TOOLSPACE > Settings tab.  

a. Expand the Corridor object collection > Expand Corridor Styles.  

 

  

 Notice how all styles have a “blue” paperclip icon next 

to the style name. The paperclip icon signifies those 

styles are attached and being controlled by a source 

reference template. 

3 

4 

5 Click OK 

6 

6a 
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Attach External Reference Drawing 

Step 1: Navigate to the Insert tab > Reference panel > Select Attach.  

a. Navigate to C:\mdtapps\Autodesk_Training\202-C3D Fundamentals-ll \References 

b. Select > 8684000GEMAP001.dwg 

c. Click Open.  

Step 2: From the Attach External Reference dialog box, verify the following parameters:  

• Reference Type = Overlay 

• Scale = Specify On-screen is unchecked 

• Insertion point = Specify On-screen is unchecked 

• Path type = Relative path 

• Rotation = Specify On-screen is unchecked 

Step 3: Click OK. 

 Locate using Geographic Data: 

If both the source and consumer 

drawing contain geographic data, the 

option is available. Both drawings 

require a matching coordinate system 

or Geolocation be assigned. If true, the 

drawing being consumed (referenced) 

will be inserted spatially correct. 

1 

3 Click OK 

2 

1a 
 

Click Open 1c 
 

1b 
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Step 4: Enter the command ZE (Zoom Extents).  

Step 5: From Model space > See the attached  

External Reference drawing in Model space. 

Create Data References 

Step 1: Navigate to TOOLSPACE > Prospector tab.  

Step 2: Right-click on Data Shortcuts.  

a. Select Set Working Folder… 

Step 3: From the Set Working Folder dialog box > Navigate to: 

• C:\mdtapps\Autodesk_Training\202-C3D Fundamentals-ll 

Step 4: Click Select Folder.  

Step 5: Verify the Data Shortcuts path has been correctly set. 

 
If there is NO Data Shortcuts path visible from the Prospector, the path has been incorrectly set or 

there is no Data Shortcut Project in the selected directory. 

3 

Click Select Folder 4 

1 

2 

2a 
 

 5 
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Step 6: From Toolspace > Prospector tab > Data Shortcuts > Expand Surfaces. 

a. Right-click on 8684000DIEFF001 surface.  

b. Select Create Reference…  

Step 7: From the Create Surface Reference dialog box > Set the surface style to: 

a. Select REF EX Contours 1-5 surface style. 

b. Click OK. 

Step 8: From the Create Surface Reference dialog box > Click OK. 

Step 9: From Toolspace > Prospector tab >  

Data Shortcuts > Expand Alignments. 

a. Expand Centerline Alignments. 

b. Expand Mainline 

c. Expand Profiles 

d. Right-click on Mainline Proposed 

e. Select Create Reference… 

 

 

6 

6a 
 6b 

 

Click OK 7b 
 

7a 
 

Click OK 8 

7 

9 

9b 
 

9a 
 

9c 
 9d 

 
9e 
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Step 10: From the Create Profile Reference dialog box >  

Accept all defaults. 

a. Click OK.  

 

 

 

Create Surface Profile and  

Display Design Profile 

Step 1: Navigate to the Home tab > Create Design panel > Click Profile drop-down.  

a. From the Profile drop-down list > Select Create Surface Profile.  

Step 2: From the Create Profile from Surface dialog box > verify and do the following: 

a. Alignment = Mainline 

b. Station Range = Default entire range 

c. Select surfaces = 8684000DIEFF001 

d. Click Add>> (Clicking Add >> will populate the Profile list with the surface profile to be created) 

e. Click Draw in profile view 

 
The Profile list contains profiles that can be drawn in a Profile View. The Mainline Proposed profile 

was previously Data Referenced into the drawing and is ready to be drawn. 

1 

1a 
 

10 

Click OK 10a 

2 
2c 
 

2b 
 

2a 
 

Click Add 2d 
 

2e 
 

Click Draw in profile view 
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Step 3: From the Create Profile View Wizard > Review each page: 

a. From the General page > Accept defaults by clicking Next >. 

b. From the Station Range page > Accept defaults by clicking Next >. 

c. From the Profile View Height page > Accept defaults by clicking Next >.  

d. From the Profile Display Options page > Set the following parameters: 

• Mainline Proposed Style / Labels = PLN Design Profile / Design Labels 

• Surface (1) Style / Labels = PLN EX Ground / _No Labels 

e. Click Next >. 

f. From the Data Bands page > Select band set > _No Bands > Click Next >. 

g. From the Profile Hatch Options page > Click Create Profile View. 

Step 4: From Model space when prompted > Select profile view origin > Pick a location in Model space 

to place the profile view. 

Step 5: From the Status Bar > Set the Annotation Scale to > 1” = 40’ 

Step 6: Enter the command ZE (Zoom Extents).  

Step 7: From Model space > See the referenced C3D objects. 

Step 8: Save the drawing .  

3 

3a-e 
 

Click Next 

3d 
 

Click Create Profile View 

3g 
 

Surface and Alignment 

Surface Profiles – Existing and Design 

7 
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Assemblies and Subassemblies 

An assembly is an Autodesk Civil 3D drawing object that manages a collection of subassembly objects that 

are used to form the basic structure of a 3D corridor model. Together, assemblies and subassemblies 

function as the basic building blocks of a roadway or other alignment-based design. An assembly object 

must be applied along an alignment to form a corridor. The assembly can reference one or more offsets 

needed for the corridor design. 

The MDT State Kit includes preconstructed assemblies for Rural 2 Lane, Rural 4 Lane, Rural Divided, 

Urban 2 Lane – Sidewalk, Ramp and Widening. In some cases, there may be the need to create a 

nonstandard assembly. The MDT State Kit provides subassemblies that can be used to create the desired 

assembly. 
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Creating an Assembly 

Step 1: Continue working with the 8684000RDCOR001-USER INITIALS.dwg. previously created. 

Step 2: Navigate to Home tab > Create Design panel, select Assembly, select Create Assembly. 

Step 3: Change the parameters shown below, click OK. 

Name: Access Road 

Assembly Type: Other 

Assembly Style: MDT Standard 

Code set style: All Codes with Hatching 

Step 4: Select a point next to the profile view, when prompted to Specify 

assembly baseline location. 

Step 5: Navigate to TOOL PALETTES > MDT Subassemblies, select LaneSuperelevationAOR.  

  

Step 6: Accept the default properties, select the assembly baseline, select Esc to end the command. 

Step 7: Navigate to TOOL PALETTES > MDT Subassemblies, select MDT Curb and Gutter. 

 
Prior to placing subassemblies, if needed, certain parameters 

can be revised and or set using the Properties palette. After 

placement, parameters can be set at any time through the 

subassembly properties. 

 
Assemblies are created at a 1:1 scale. When you select a point on the screen to insert the baseline, 

Civil 3D will automatically zoom you to its location. 

2 

5 

6 

3 

Click OK 
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Step 8: Accept the defaults properties, select the upper right point of the LaneSuperelevationAOR 

subassembly, select Esc to end the command. 

Step 9: Navigate to TOOL PALETTES > MDT Subassemblies, select MDT Daylight Urban. 

Step 10: Accept the defaults properties, select the back of curb point of the MDT Curb and Gutter 

subassembly, select Esc to end the command. 

Mirroring Subassemblies 

Step 1: Select the LaneSuperelevationAOR, MDT Curb and Gutter and MDT Daylight Urban 

subassemblies, navigate to Modify Subassemblies panel on the contextual ribbon, select 

Mirror. 

 
AutoCAD commands should not be used on Subassemblies. The Modify Subassembly Move, 

Mirror and Copy commands must be used. AutoCAD Move and Copy commands should only be 

used for the Assembly. 

1 

8 

10 
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Step 2: Select the assembly base line > Press Esc to end the Mirror command. 

Organizing Subassemblies 

Step 1: Select the assembly baseline, navigate to Modify Assembly panel, select Assembly 

Properties.  

Step 2: Select Construction tab in the assembly Properties dialog box, rename the subassemblies _RT 

for right side and _LT for left side, click OK., press Esc to deselect the baseline. 

  Right     Left 

LaneSuperelevationAOR_RT  LaneSuperelevationAOR_LT 

MDT CurbAndGutter_RT  MDT CurbAndGutter_LT 

MDT Daylight_RT   MDT Daylight_LT 

2 

1 

2 

Click OK 
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Naming an Assembly 

Step 1: Type FIELD at the command line, select Enter. 

Step 2: Select Objects from the Field category, select Object from the Field names, select the green 

box for the Object Type. 

Step 3: Select the assembly baseline when prompted to Select object. 

2 
2a 
 

2b 
 

2c 
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Step 4: Select Name for the Property, select Uppercase for the Format, click OK. 

Step 5: Select a point near the assembly baseline to place the Field in the drawing. 

Step 6: Select the Field, right click and select Properties, change the Text height to 1, close the 

properties palette, press Esc to deselect the field text. 

4 

4a 
 

4b 
 

Click OK 

6 

6a 
 

6b 
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Step 7: Select the assembly baseline, navigate to Modify Assembly panel, select Assembly 

Properties. 

Step 8: Navigate to the Information tab, change the name to Access Road Urban, click OK. 

Step 9: Press Esc to deselect the assembly baseline. 

Step 10: Type RE, select the Spacebar to regenerate the view. 

Step 11: Save the drawing .  

  

 
Fields can be used to add text links to drawing components. If the drawing component updates, 

the Field will update as well. 

7 

8 

Click OK 
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Leveraging an MDT Assembly for corridor design 

Step 1: Navigate to TOOL PALETTES > MDT Assemblies, select MDT Rural 2 Lane, accept the default 

properties, pick a point on the screen to place the assembly, select Esc to end the command. 

Step 2: Select the assembly baseline, navigate to Modify Assembly panel, select Assembly 

Properties. 

Step 3: On the Information tab, rename the Assembly to Mainline.  

2 

3 
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Step 4: Select the Construction tab, select Right_MDTParameterReferences. 

 
The MDT Assemblies use a parameter reference subassembly to control the parameters of 

subassemblies attached to the assembly baseline. To make a parameter change for slope, depth, 

or width, the value in the parameter references will need to be changed. 

4 
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Step 5: From the Construction tab, select Right_LaneSuperelevationAOR – Lane. 

Step 6: From the Construction tab, select Right_MDTParameterReference, change the Lane 1 Slope 

to -5.00%, click Apply.  

 
Notice the Width, Default Slope, Pave1 Depth, Pave2 Depth, Base Depth and Sub-base Depth 

“Default Input Values” are not editable and the “Get Value From” is leveraging the 

Right_MDTParameterRefernces values. To make a value change to the 

Right_LaneSuperelevationAOR – Lane subassembly the value must be changed at the Parameter 

Reference level. 

5 

6 

Click Apply 
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Step 7: Change the Lane 1 Slope to back to -2.00%, click OK, press Esc to deselect the baseline. 

Create a Corridor 

Step 1: Navigate to Home tab > Create Design panel > Corridor, select Corridor. 

Step 2: Change the following parameters, click OK. 

Name: Mainline 

Corridor Style: MDT DES Corridor 

Baseline type: Alignment and profile 

Alignment: Mainline 

Profile: Mainline Proposed 

Assembly: Mainline 

Target Surface: 8684000DIEFF001 

Set baseline and region parameters: Uncheck 

1 

2 

Click OK 
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Step 4: Select Action, select Clear All Events, close the PANORAMA. 

Step 5: Type ZE + spacebar to zoom extents. 

Step 6: Zoom to the southeast end of the Corridor. See the corridor. 

 

Corridor Frequency 

Corridor Frequencies are used to specify an incremental value of where to place an assembly along a 

corridor. Station frequency can be specified by referencing portions of an alignment and profile geometry 

in a region. For example, you can specify assembly insertion frequency for the following components of a 

corridor region: 

• Along Tangents - Specify the assembly insertion frequency along the tangent portion of an 

alignment. 

• Along Curves - Specify the assembly insertion frequency along the curve portion of an alignment. 

• Along Spirals - Specify the assembly insertion frequency along the spiral portion of an alignment. 

• Along Profile Curves - Specify the assembly insertion frequency along the curve portion of the 

profile. 

• At Specific Points - Specify whether assemblies should be inserted at specific geometry points, 

including horizontal geometry, superelevation critical, profile geometry, and profile high and low 

points. 

• Along Offset Targets - Specify whether assemblies should be inserted based on offset targets. 

4 

4a 
 

4b 
 

6 
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Adjusting Corridor Frequencies 

Step 1: Select the Corridor, select Corridor Properties on the contextual ribbon. 

Step 2: In the Corridor Properties dialog box, select the Parameter tab, select Set all Frequencies. 

  

1 

2 

2a 
 

2b 
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Step 3: Change the following Values as shown, click OK. 

Along tangents: 10.000’ 

Curve increments: 10.000’ 

Along spirals: 10.000’ 

Along vertical curves: 10.000’ 

Step 4: Click OK on the Corridor Properties dialog 

box. 

Step 5: Select Rebuild the Corridor from  

the Corridor Properties – Rebuild pop-up 

window. 

Be patient while the corridor updates. 

 

 

 

Step 6: Select Action, select Clear All Events, close the PANORAMA, press Esc to deselect the 

corridor. 

3 

Click OK 

6c 

6a 
 

6b 
 

6 

5 
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Step 7: Select the Corridor, select Corridor Properties on the contextual ribbon. 

Step 8: In the Corridor Properties dialog box, select the Parameter tab, select Set all Frequencies. 

 
Notice not only the frequencies intervals increased, by applying additional frequencies, the corridor 

end conditions have smoother transitions as well.  

 
By increasing the corridor frequencies, a more accurate depiction of the corridor model is 

presented. Use caution when increasing frequencies. The smaller the value the slower the corridor 

rebuild process will be and the drawing performance will decrease. Increasing the corridor 

frequencies should be applied after the design process and during the calculating volumes and 

materials process. 

8 

8a 
 

8b 
 

7 
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Step 9: Change the following Values as shown, click OK. 

Along tangents: 50.000’ 

Curve increments: 50.000’ 

Along spirals: 50.000’ 

Along vertical curves: 50.000’ 

Step 10: Click OK on the Corridor Properties dialog 

box. 

Step 11: Select Rebuild the Corridor from  

the Corridor Properties – Rebuild pop-up 

window. 

Be patient while the corridor updates. 

 

Step 12: Select Action, select Clear All Events, close the PANORAMA, , press Esc to deselect the 

corridor. 

9 

Click OK 

12 

12a 
 

12b 
 

11 



202 – Civil 3D Fundamentals – ll User Guide 

 

 

30 MDT Internal Use Only 

Solving Event Viewer Errors 

Step 1: Zoom to the Mainline Profile, notice that the proposed profile doesn’t begin at the alignments 

starting station or extend to the ending station of the alignment. 

Step 2: Select the Mainline Proposed Profile, select Profile Properties from the contextual ribbon.  

Step 3: On the Profile Properties, select Profile Data tab, note the Start and End stations, click OK, 

press Esc to deselect the Mainline Proposed Profile. 

 

  

 
A corridor leverages horizontal data from an alignment and vertical data from a profile. When the 

alignment and profile starting and ending stations do not match, the Event Viewer will populate 

with errors. To resolve the errors, in this case, the corridor starting and ending stations need to be 

adjusted to match the profile stationing. 

2 

3 

Click OK 
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Step 4: Navigate to TOOLSPACE > Prospector tab, expand Corridors, right click on Mainline, select 

Properties. 

Step 5: In the Corridor Properties dialog box, select Parameters 

tab, change the Start Station to 225+92.00 and End Station 

to 391+19.21, click OK. 

Step 6: Select Rebuild the Corridor from  

the Corridor Properties – Rebuild pop-up window. 

Be patient while the corridor updates. 

Corridor Targets and Target Types 

Corridor targets can be leveraged to specify horizontal widths adjustments, vertical adjustments from 3D 

polylines o, feature lines or survey figures and for surface projections. Targets are required when the 

geometry of one or more of an assembly’s subassemblies requires corresponding surface, offset, or 

elevation targets for defining that geometry. When a corridor contains subassemblies that use targets, the 

object names of the intended target objects must be mapped from the subassembly definition to the 

corresponding drawing objects. This task is referred to as setting targets or mapping targets. 

Step 1: Zoom to Station 265+00 of the Mainline Alignment, notice the turnout area.  

 

 
The Station Offset Transparent command can be used to 

easily locate specific stations along an alignment. From the 

Transparent ribbon tab, select Station Offset from the Plan 

panel. When prompted, select desired alignment from 

Model space. From the Station Offset contextual tab, verify 

the desired alignment is current, enter the desired station, 

from Model space, see the Cross Hairs locked to the 

location. Press Esc to end the command. 

4 

5 

Click OK 

1 

6 
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Step 2: Select the Mainline Corridor, right click and select Corridor Properties. 

Step 6: In the Corridor Properties dialog box, select Set all Targets. 

Step 4: In the Target Mapping dialog box, select the Collapse all button, expand 

Right_LaneSuperelevationAOR – Shld, select Width Target, select pick from screen button. 

2 3 

4 

4a 
 

4b 
 

4c 
 

4d 
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Step 5: Select the red line representing the turnout, select Enter on the keyboard to return to the Target 

Mapping dialog box. 

Step 6: Select OK on the Target Mapping dialog box.  

Step 7: Select OK on the Corridor Properties dialog box, select Rebuild the corridor.  

Be patient while the corridor updates. 

Step 8: Select Action, select Clear All Events on the Event Viewer, close the Event Viewer. 

Step 9: From Model space, review the 

adjusted Turn Out area of the 

corridor. 
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Understanding and Using Regions 

Corridor regions are used to associate assemblies to a specific range of stations along the corridor. Corridor 

regions can be created to specify different assemblies along the corridor at locations that may not be 

common to the overall design. For example, a corridor region can be created at an intersecting access road 

or intersection where the need for an end condition, cut or fill condition, is not needed. Regions can also be 

leveraged to organize the Corridor. Regions can be created to divide lengthy corridors into more 

manageable sizes, helping the rebuilding speed. Corridor regions can be turned off when not being focused 

on and turned back on when needed. 

Creating Corridor Regions 

Step 1: Select the Mainline corridor, right click and select Corridor Properties. 

Step 2: Right click on RG – Mainline (1), select Split Region. 
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Step 3: Select Shift + right click, select Endpoint, pick the northerly endpoint of the turnout  

(red Xref target line), repeat for the southerly end, select Enter to return to Corridor Properties. 

If presented with the Station 0+00.00’ warning pop-up, click OK. 

• This warning is common when working with corridors and regions. 

Step 4: Rename the RG – Mainline – (2) to RG – Mainline – Turnout, Select the Target button for RG – 

Mainline – (1).  

3b 
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Step 5: In the Target Mapping dialog box, select Collapse all button, expand 

Right_LaneSuperelevationAOR – Shld, select Width Target, uncheck 

8684000GEMAP001|C-ROAD-PVMT-WIDN, click OK.  

Step 6: Repeat for RG – Mainline – (3). 

Step 7: From the Corridor Properties – Mainline dialog box, click OK, select Rebuild the corridor. 

Be patient while the corridor updates. 

 

Corridor Surfaces 

Once a corridor has been created, a corridor surface can be generated. Corridor surfaces are an output of 

a corridor model, they remain dynamically linked to the corridor. Any changes to the corridor definition are 

reflected in the surface definitions. The Surfaces tab of the Corridor Properties dialog box is used to create 

corridor surfaces. Corridor surfaces can be created from corridor links and features lines. 

Create a Corridor Surface 

Step 1: Select the Mainline corridor, right click and  

select Corridor Properties. 
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Step 2: Select the Surfaces tab in the Corridor Properties dialog box, select the Create a corridor surface 

button. 

Step 3: Rename the surface to Mainline Surface – TOP, change the Surface Style to 

PLN Prop Contours 1-5, set the Overhang Correction to Top Links. 

Step 4: Verify the Data type is Links and Specify code is Top, select green plus button .  

 
Overhang Correction forces the corridor surface to use either the Top links or Bottom links of 

the subassembly(s). In some cases, the corridor surface will use a variation of links to create 

the surface. By selecting Top links or Bottom links it will ensure the correct links are being 

leveraged for the desired corridor surface. 
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Step 5: Select the check box for Add as Breakline. 

Step 6: Select the Create a corridor surface button, rename the Surface to Mainline Surface – DATUM, 

change the Surface Style to _No Display, select Bottom Links for Overhang Correction. 
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Step 7: Verify the Data type is Links and Specify code is Datum, select green plus button, select the 

check box for Add as Breakline, click OK.  

Corridor Boundaries 

Corridor surface boundaries are used to prevent triangulation outside the extents of a corridor. Corridor 

surface boundaries can be created using the following options: 

• Corridor Extents As Outer Boundary – Trims the triangulation of a surface at the extents of a 

corridor (Shrink Wrap). 

• Add Automatically – Based on point codes to which feature lines are assigned. A single baseline 

must exist for this option. 

• Add interactively – Allows for feature lines from the corridor to be selected and used as boundary. 

• Add from Polygon – Uses a closed polyline as the corridor boundary extents. 

7 
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Create a Corridor Surface Boundary 

Step 1: Select the Mainline corridor, right click and  

select Corridor Properties.  

Step 2: Select the Boundaries tab, right click on Mainline Surface – TOP, select Corridor extents as 

outer boundary, repeat for Main Surface – DATUM, click OK, select Rebuild the corridor. 

Corridor Section Editor 

The Corridor Section Editor can be used to view and modify corridor sections and to visually inspect how 

assemblies are applied at various stations. The Corridor Section Editor can be leveraged to apply assembly 

overrides to a corridor section or a range of sections. 

Section Editor Overview and User Interface 

 

Baseline & Offsets panel: 

 

Select a Baseline – Specify a baseline alignment for a corridor to view and edit sections. Selecting the 

down arrow allows for selecting available alignments. 

 - Used to select a baseline from the drawing. 
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Station Selection panel: 

 

- Display the first or start station on the corridor.  

- Steps to previous corridor station. 

- Filters the Select a Station list by type of station. All Baseline, Region, Overridden or Non-region. 

Select a Station – Lists all baseline stations and allows selection of a station to view. 

 - Steps to the next corridor station. 

 - Displays the corridor section at the first station of the next region. 

 - Display the corridor section view at the end station on the corridor. 

 - Select a station from the drawing or by entering a station value. 

 

 

Corridor Edit Tools Panel: 

Parameter Editor – Allows for corridor parameter overrides to be applied to a station or range of stations. 

Change Assembly – Allows for swamping an assembly at a station or range of stations. 

Apply to a Station Range – This tool can be used once the Parameter Editor or Change Assembly tools are 

applied. 

Update Corridor – Used to rebuild/update the corridor. 

Add a Region – used to add a region to the corridor. 

 

Analyze panel: 

Station Tracker – Used to visually see which station is currently selected. Allows the station tracker to be 

visible in the current viewport, all viewports or turned off. 
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View Tools: 

Zoom – Used to Zoom Extents of the assembly, Zoom to a station or offset or assembly. 

View/Edit Options – Controls the visibility of the Section Editors objects. Scale, grid, grid text, section slider 

and code set style. 

Viewport Configuration – Controls the number of viewports and which views, plan, profile, section or 

assembly, is displayed in each viewport. 

Display Objects - Controls which objects are displayed in the Section Editor. 

Using the Corridor Section Editor 

Step 1: Select the Mainline Corridor, navigate to Modify Corridor Sections panel on the contextual 

ribbon, select Section Editor.  

Step 2: In the Section Editor, navigate to View Tools, select Viewport Configuration. 

a. If the Corridor Section Editor – Viewport Configuration warning pop-up appears, click Yes. 

Step 3: Choose the following parameters, Click OK.  

3 

Click OK 
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Step 4: Change the annotation scale to 1” = 20’.  

Step 5: Navigate to Station Selection panel, select station 264+00.00’ from the Select a Station tool. 

Step 6: Select the Got to Next Station button, advance through the widening area of the corridor. Notice 

the Right_LaneSuperelevationAOR – Shld width increases through the turn out. 

 

5 
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Step 7: Navigate to View Tools panel, select View/Edit Options, change the following settings in the 

View/Edit Corridor Section options dialog box, click OK. 

Step 8: Select Close to close the Section Editor . 

Step 9: Save the drawing . 
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Cross Sections 

In Autodesk Civil 3D, section data is defined and displayed using sample lines, sections, and section views, 

all of which are managed through a collection called a sample line group. An alignment can have more than 

one sample line group associated with it, each having a unique set of sample lines and sections. 

Use sections (also referred to as cross sections) to provide a view of the terrain cut at an angle across a 

linear feature, such as a proposed road. 

Typically, sections are cut across horizontal (plan) alignments at a specified station interval using specified 

swath widths. These sections are then plotted, individually for a station, or as a group for a range of stations. 

Autodesk Civil 3D handles the creation, management, and plotting of sections with the following 

components: 

• Sections - Terrain elevations that cut across surfaces, including corridor surfaces, which are 

associated with a specified sample line group. Elevations are sampled at each of the sample line 

XY vertices and also at locations where the vertical plane defined by the sample line intersects with 

surface edges. 

• Section Views - For each sample line, views displaying some or all of the sections sampled at that 

sample line. This graphical view has both horizontal limits based on the length of corresponding 

sample line and vertical values based on the minimum and maximum elevations from the set of 

sections it is displaying. 

• Section Sheets -Production-quality section layouts for plotting. 

 

Sample Lines 

A Sample Line is a linear plan object representing the direction along which sections are cut for a set of 

specified surfaces. Sample lines are linear objects that are used to cut sections across an alignment. 

Sample lines have their own styles and label styles. A set of sample lines makes up a named collection 

called a sample line group. A sample line group centrally manages the display styles and label styles for 

several sample lines, sections, section views, and mass haul lines and mass haul views. 

Create a Section drawing 

Step 1: From the Start tab > Create a new drawing using the Standard: design-start.dwt 

• C:\MDOH\StateKit\Civil 3D\2022\Templates\_Start-Dwg 

Step 2: Save and Name the drawing: 8684000RDXS001-USER INITIALS.dwg 

• C:\mdtapps\Autodesk_Training\202-C3D Fundamentals-ll\Working 

 

If the Working Folder is still correctly set to 202-C3D Fundamentals II, skip ahead to Step 6.  

1 
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Step 3: Navigate to TOOLSPACE > Prospector tab > Data Shortcuts, right click on Data Shortcuts, 

select Set Working Folder. 

Step 4: Browse to C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II, select Folder. 

 

Step 5: Verify the Data Shortcuts path has been set.  

Step 6: Navigate to Data Shortcuts > Surfaces, expanded Surfaces. 

Step 7: Right click on 8684000DIEFF001, select Create Reference. 

Step 8: In the Create Surface Reference dialog box, change the Style 

to REF Ex Contours 1-5, select OK in the Select Surface 

Style dialog box, select OK in the Create Surface Reference 

dialog box. 
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Step 9: Type ZE, select Enter on the keyboard to Zoom Extents. 

Step 10: Navigate to Data Shortcuts > Alignments, expanded Alignments, expand Centerline 

Alignments, right click on Mainline, select Create Reference. 

Step 11: On the Create Alignment Reference dialog box, change the following parameters, click OK. 

Sharing Data between Drawing Files 

Step 1: Navigate to 8684000RDCORR001-USER INITIALS.dwg drawing tab, select the tab making it 

current. 

• If the 8684000RDCORR001-USER INITIALS.dwg was closed previously, open the drawing. 

Step 2: Navigate to Data Shortcuts, right click, select Create Data Shortcuts. 

10 

Click OK 
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Step 3: Check Surfaces and Corridors boxes from the Create Data Shortcuts dialog box, click OK. 

Step 4: Navigate to 8684000RDXS001.dwg drawing tab, select the tab making it current. 

Step 5: Navigate to Data Shortcuts, expand Surfaces, right click Corridor Surface – DATUM, select 

Create Reference, change the style to _No Display in the Create Surface Reference dialog box, 

select OK. 

Step 6: Repeat Step 5 for Corridor Surface – TOP, change the style to PLN Prop Contours 1-5, 

select OK. 
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Step 7: Navigate to Data Shortcuts, expand Corridors, right click Mainline, select Create Reference, 

change the style to MDT DES Corridor in the Create Corridor Reference dialog box, select OK. 

Step 8: Save 8684000RDXS001.dwg. 

Generating Sample Lines 

Step 1: Change the Annotation scale to 1” = 20’, navigate to Home tab > Profile & Section Views panel, 

select Sample Lines. 
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Step 2: Select Enter to select Alignment from list, select Mainline from the Select Alignment dialog box, 

click OK. 

Step 3: In the Create Sample Line Group dialog box, change the following parameters, click OK. 

Name: SLG-Mainline 

Sample line style: MDT Sample Line 

Sample line label style: Section Station 

8684000DIEFF001 style: MDT Existing Ground 

Mainline style: PLN XSec 

Mainline Corridor Surface – TOP style: MDT Finished Ground 

Mainline Corridor Surface – DATUM style: MDT Finished Ground 

2 

Click OK 

3 

Click OK 
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Step 4: On the Sample Line Tools tool bar, select By range of stations. 

Step 5: In the Create Sample Lines dialog box, change the following parameters, click OK, select Esc 

to end the command. 

Step 6: Save 8684000RDXS001.dwg. 
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Section Views 

Section views are created from existing sample lines and sections. A section view consists of a grid on 

which one or more sections are displayed as graphed lines. Multiple section views can be plotted on a 

sheet that is a specified size and configuration. A section view is very similar to a profile view. It consists of 

a grid or graph with specific characteristics that are controlled by section view styles. Bands can also be 

displayed above or below the section view. A section view can display one or more of the available sections 

at the sample line. Sections can be created as a single section for one sample line or multiple sections from 

all the sample lines in a sample line group. Objects can be projected in section view including COGO points, 

AutoCAD points, 3D solids, blocks, multi-view blocks. Crossing objects can be shown in a section view 

including feature lines, 3D polylines and survey figures.  Additionally, pipe network and pressure network 

structures and pipes can be displayed in section views. 

Create Section Views 

Step 1: Navigate to the Home tab > Profile & Section Views panel, select Section Views, select Create 

Multiple Views from the drop-down list. 

Step 2: In the Create Multiple Section Views dialog box, change the following parameters, click Next. 
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Step 3: On the Section Placement, verify the following parameters, click Next. 

Step 4: Select Next for the Offset Range and Elevation Range. 

Step 5: On the Section Display options, change the following Label Sets, click Next. 

3 

Click Next 
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Step 6: On the Data Bands, select _No Bands, click Create Section Views. 

Step 7: When prompted to Identify section view origin, select a point within the drawing to place the 

section views. 
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Section View Labeling 

Sections can be automatically labeled when creating them or after. Section labels can include Major and 

Minor Offsets, grade breaks, segments, and corridor points. A section label set can be created from one or 

more label styles.  

• Major Offsets - Offsets, elevations, and instantaneous grades at major increments.  

• Minor Offsets - Offsets, elevations, and instantaneous grades at minor increments. 

• Segments - Section segment labels for each segment (line) of a section object. A user-specified 

weeding factor is supported, thus avoiding close annotation. 

• Grade Breaks - Grade break labels applied at every grade break point for a section. A user-

specified weeding factor is supported, thus avoiding close annotation. 

• Corridor Points - Corridor point codes using a code set style or a section label set. Corridor points 

label style can be staggered, so they don’t overlap. 

• Label Sets – A group of section labels used for sections when a section view object is created. 

Create Section View Labels 

Step 1: Zoom to Sample Line 260+00.00, select the sample line, right click and select Zoom to Section 

View. 

Step 2: Select the section view, select View Group Properties from the contextual ribbon. 

 

 
If a corridor has been sampled in a section view and the PLN XSec style is assigned to the corridor, 

the MDT State Kit is setup to automatically label it using a code set style. 
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Step 3: Select the Mainline corridor style, change the style to DES Corridor, click OK to close the 

Code Set Style dialog box, click OK to close the Section View Group properties. 

 

Step 4: Select the section view, select View Group Properties from the contextual ribbon. 
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Step 5: Select the Mainline Surface - TOP Label Set, change the Label set to FG Section Labels, 

click OK to close the Label set dialog box, click OK to close the Section View Group properties. 

 Step 6: Select the section view, select View Group Properties from the contextual ribbon. 
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Step 7: Select the Mainline Surface - TOP Label Set, change the Label set to _No Labels, click OK to 

close the Label set dialog box. 

Step 8: Select the Mainline corridor style, change the style to PLN XSec, click OK to close the Code 

Set Style dialog box, click OK to close the Section View Group properties.  
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Step 9: Press Esc to deselect the Section View, save the drawing 

Earthwork and Materials 
Earthwork and material volumes are calculated by comparing two surfaces to each other. Quantities Can 

be calculated between sample lines derived from regular surface models and from corridor surfaces. User-

definable tables specify which materials are defined by which surfaces, and the characteristics of these 

materials. Finally, average end area analysis is used to tabulate the material quantities along the corridor. 

Earthwork Volumes 

Calculating earthwork volumes in Civil 3D can be achieved using various methods. They can be calculated 

using corridors and sample lines, the Volumes Dashboard and by creating a grid or tin volume surface. 

Grading volume tools can be leveraged for grading as well. 

Corridor Surface Volumes 

Continue working in the 8684000RDXS001-USER INITIALS.dwg 

Step 1: Navigate to Analyze tab > Volumes and Materials panel, select Computer Materials. 

Step 2: Verify the Select alignment is Mainline, verify Select 

sample line group is SLG – Mainline. click OK. 
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Click OK 



202 – Civil 3D Fundamentals – ll User Guide 

 

 

60 MDT Internal Use Only 

Step 3: In the Compute Materials dialog box, select Cut and Fill for the Quantity takeoff criteria, select 

868400DIEFF001 for the EG Surface, select Corridor Surface – DATUM for the Datum surface, 

click OK. 

 

  

 
Selecting <Click here to set all> allows for setting the EG and Datum surface for both Ground 

Removed and Ground Fill. 

 
Notice the section views now show the Cut and Fill. This can easily be turned off in the View Group 

properties. 
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Step 5: Select one of the section views, right click and select Section View Group Properties. 

Step 6: In the Section View Group Properties, select the Section tab, Uncheck Ground Removed and 

Ground Fill, click OK, press Esc to deselect the Section View. 

Step 7: Navigate to Analyze tab > Volumes and Materials panel, select Computer Materials. 
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Click OK 
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Step 8: Select OK on the Select a Sample Line Group dialog box. 

 

 

 

 

Step 9: In the Edit material List dialog box, Rename Materials List (1) to Cut-Fill. 

Remain in the Edit Material List – SLG-Mainline dialog box. 

Material Volumes 

Once a corridor has been sampled, materials can be calculated using the Compute Materials tools. Corridor 

shapes are leveraged by the tool to compute the materials found within the corridor’s assembly. A volume 

table can be created from the computed materials and displayed. The computed materials can be displayed 

in cross sections along with a materials table. 

Creating a Materials List 

Step 1: In the Edit Materials List dialog box, select Import another criteria, select Materials List from 

the Select a Quantity Takeoff Criteria dialog box, click OK. 
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Step 2: In the Compute Materials dialog box, select Mainline Pave1 for Pavement Material, select 

Mainline Base for the Base Material, select Mainline SubBase for the SubBase Material, click 

OK. 

Step 3: Rename Materials List (2) to Pavement, click OK. 

Step 4: Select one of the section views, right click and select Section View Group Properties. 

 
Notice the section views now show the Cut and Fill. This can easily be turned off in the View Group 

properties. 
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Step 5: In the Section View Group Properties, select the Sections tab, Uncheck Pavement, Base and 

SubBase, click OK. 

Generating Volume Reports and Table 

Reporting of the calculated earthwork and materials can be accomplished in Civil 3D using the Volume 

Report tool. The report can be saved or printed. 

Generating Volume Reports 

Step 1: Navigate to Analyze tab > Volumes and Materials panel, select Volume Report. 

Step 2: In the Report Quantities dialog box, select Mainline for the 

alignment, select SLG-Mainline for the sample line group, 

select Cut-Fill for the material list, select browse for the style 

sheet. 
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Step 3: In the Select Style Sheet dialog box, select earthwork.xsl, click Open. 

Step 4: In the Report Quantities dialog box, uncheck Display XML report, Click OK. 

Step 5: Click Yes on the Internet Explorer dialog box warning about 

Scripts, click Yes on the second warning, close Internet 

Explorer.  

Click Open 
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Step 6: Repeat steps 1-5, selecting Pavement for the materials list, select Select Materials.xls for the 

style sheet, close Internet Explorer. 

Creating Volume Tables 

Step 1: Navigate to Analyze tab > Volumes and Materials panel, select Total Volume Table. 

Step 2: In the Create Total Volume Table dialog box, verify the following parameters, click OK. 

 Table style: Cut and Fill 

 Select material list: Cut-Fill 

Step 3: Select a point within the workspace to place the table. 

1 

2 

Click OK 
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Step 4: Select the Total Volumes Table, select Table Properties from the contextual ribbon. 

Step 5: In the Table properties dialog box, change Maximum rows per table to 21, click OK. 

  

5 

Click OK 
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Creating Material Tables 

Step 1: Navigate to Analyze tab > Volumes and Materials panel, select Material Volume Table. 

Step 2: In the Create Materials Volume Table dialog box, verify the following parameters, Click OK. 

Select material list: Pavement 

 Select a material: Pavement 

 Maximum rows per tale: 21 

 

Step 3: Select a point within the workspace to place the 

table. 
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Pipe Networks 

Autodesk Civil 3D Pipe Network tools assist in creating gravity utility systems. A pipe network can contain 

pipes only, structures only, or, more commonly, both pipes and structures. A part catalog provides access 

to pipe network items, such as circular, elliptical, or rectangular pipes, manholes, catch basins, and 

headwalls, and more. A pipe network object manages a collection of pipe objects and structure objects that 

are associated with each other to represent a pipe system. Typically, the pipes and structures are 

connected to each other, forming a single pipe run or pipe network. The pipe and structure objects in a pipe 

network can be associated with a referenced alignment and or a surface, which provide them with station 

offset and elevation data. Each part in a pipe network can reference any given surface or alignment in the 

drawing. 

Part Catalogs and Part List 

The pipe networks feature references a part catalog and a parts list that define the size, shape, and certain 

behavior of the pipes and structures insert into drawings. The part catalog content is organized into types, 

subtypes (part shapes), and part families. A parts list contains a set of pipe network parts, pipes and 

structures, that can be used in a pipe network. A parts list also serves as a way to store defaults, such 

as styles, render materials and design criteria (rules) to any given part upon creation. 

Create a culvert drawing 

Step 1: From the Start tab > Create a new drawing using the Standard: design-

start.dwt  

Step 2: Save and Name the drawing:  

• C:\mdtapps\Autodesk_Training\202-Civil 3D Fundamentals II\Working 

• 8684000RDCULV001-USER INITIALS.dwg 

If the Working Folder is still correctly set to 202-C3D Fundamentals II, skip ahead to Step 6. 

Step 3: Navigate to TOOLSPACE > Prospector tab > Data Shortcuts, right click on Data Shortcuts, 

select Set Working Folder. 

Step 4: Browse to C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II, select Select Folder. 

 

1 

3
 4

 

Select 



202 – Civil 3D Fundamentals – ll User Guide 

 

 

70 MDT Internal Use Only 

Step 5: Verify the Data Shortcuts path has been set.  

Step 6: Navigate to Data Shortcuts > Surfaces, expanded Surfaces. 

Step 7: Right click on 8684000DIEFF001, select Create Reference. 

Step 8: In the Create Surface Reference dialog box, change the Style 

to REF Ex Contours 1-5, select OK in the Select Surface 

Style dialog box, select OK in the Create Surface Reference 

dialog box. 

Step 9: Type ZE, select Enter on the keyboard to Zoom Extents. 

Step 10: Navigate to Data Shortcuts > Corridors, expanded Corridors, right click on Mainline, select 

Create Reference. 
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Step 11: In the Create Corridor Reference dialog box, select MDT DES Corridor for the Corridor style, 

click OK. 

 

 

Preparing the drawing for Pipe Network Objects 

Step 1: Navigate to Home tab> Create Design panel, select Create 

Design drop down, select Set Pipe Network Catalog. 

Step 2: Select US Imperial Pipe Catalog for Pipe Catalog, select Montana Department of 

Transportation Drainage for Structure Catalog, click OK. 

Step 3: Navigate to TOOLSPACE > Settings tab, expand Pipe 

Network, expand Parts Lists, right click on MDT Drainage 

Parts, select Edit. 

 

 
Corridors are dependent on the alignment and profile it was 

created with. When a Corridor is data referenced it will bring along 

the alignment and profile data references as well. 

11 

Click OK 
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Step 4: In the Network Parts List dialog box, select Pipes tab, expand MDT RCP. 

Step 5: Select Structures tab, expand Type 3 Manhole, click Cancel. 
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Pipe and Structure Rules 

Part rules are properties that affect how pipe network parts behave on creation and when you move or edit 

them. Part rules automatically determine reasonable elevations for parts as they are created. The specific 

elevation behavior you see is based on choices you make, such as how you define the minimum slope, 

minimum cover, and desired drop across a structure. Rules also provide automatic validation of your pipe 

network design, such as checking to see if a structure is too small to accommodate a pipe size, if the length 

of a pipe is greater than desired, or the maximum cover above a pipe is exceeded. Rules provide an 

excellent way to give a good starting point for design. 

Autodesk Civil 3D pipe network objects use part rules in the following ways: 

• To determine elevations for pipes and structures when they are created. 

• To determine how pipes connect to junction structures. 

• To warn that certain criteria is not met while creating or editing pipe networks. 

Exploring Pipe Rules 

Step 1: Navigate to TOOLSPACE > Settings tab, expand Pipe, expand Pipe Ruel Set, right click on 

MDT Basic Pipe Rule, select Edit. 

Step 2: In the Pipe Rule Set dialog box, select Rules tab, expand Cover Only, expand Length Check, 

click Cancel. 

  
1 2 

Click Cancel 
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Creating Pipe Networks 

There are several ways to create pipe networks. Pipe network can be created by using the Network 

Layout Tools toolbar or from objects including lines, arcs, polylines, both 2D and 3D, feature lines and 

alignments.  

Referencing Existing Culverts 

Step 1: Navigate to the Insert tab > Reference panel > Select Attach.  

a. Navigate to C:\mdtapps\Autodesk_Training\202-Civil 3D Fundamentals II\References 

b. Select > 8684000DIMAP001.dwg 

c. Click Open. 

  

Step 2: From the Attach External Reference dialog box, verify the following parameters:  

• Reference Type = Overlay 

• Scale = Specify On-screen is unchecked 

• Insertion point = Specify On-screen is unchecked 

• Path type = Relative path 

• Rotation = Specify On-screen is unchecked 

Step 3: Click OK. 

1 
1a 
 

1b 
 

Click Open 1c 
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Step 4: Zoom to station 248+00.00 of the Mainline alignment. 

Step 5: Save the drawing. 

Pipe Network from Object 

Step 1: Navigate to Home Tab > Create Design panel > Pipe 

Network, select Create Pipe Network from Object. 

Step 2: Select Xref from the command line, select the blue line representing the existing culvert, select 

Enter to accept the Northeast flow direction. 

Step 3: Make the following parameter changes, click OK. 

 Network name: Drainage 

 Network parts list: MDT Drainage Parts 

 Pipe to create: 48: RCP 

 Structure to create: Type A Concrete Flared End Section 

48.00 diameter 98.00 L X 94.00 W 

 Surface name: 8684000DIEFF001 

 Alignment name: Mainline 

 Use vertex elevations: check 

 Vertex Elevation Reference: Invert 

1 
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Click OK 
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Step 5: Select the northerly flared end section, select the circle grip, rotate the flared end section to 

align with the culvert. 

Step 6: Select the culvert pipe, navigate to Modify panel, select 

Edit Pipe Network. 

 

 

Extending Existing Culverts 

Step 1: On the Network Layout Tools tool bar, select Type A Concrete Flared End Section 48.00 

diameter 98.00 L X 94.00 W, select 48” RCP, select toggle upslope, select Pipes and 

Structures. 

Step 2: Zoom to the southerly end of the existing culvert pipe, hover the crosshairs over the existing 

culvert pipe, select the existing structure when the connect to structure symbol appears. 

5 
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Step 3: Extend the new pipe to the edge of the corridor, select a point near the corridor limit, select 

Esc to end the command. 

Step 4: Select the existing structure, select Delete on the keyboard. 

Step 5: Select a structure, select a pipe, right click and select Select Similar, right click again and 

select Object Viewer. 

Step 6: In the Object Viewer application window, select Shades of Gray for the Visual Style, select SE 

Isometric for the View Control, press ESC when done viewing to close the Object Viewer. 

 
The new pipe culvert will need to be edited to match the invert of the existing pipe culvert. The 

invert of the existing pipe culvert is shown on the cogo point. To get the elevation of the surface a 

surface spot elevation can be added to the drawing. 

BEFORE AFTER 
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Step 7: Select the 8684000DIEFF001 surface, navigate to Labels & Tables panel on the contextual 

ribbon, select Add Labels, select Spot Elevations. 

Step 8: Select a point on the surface near the end of the new pipe culvert. 

Step 9: Select the new 48” pipe, select Pipe Properties from the contextual ribbon.   

Step 10: In the Pipe Properties dialog box, select the Part Properties tab, edit the Start Invert Elevation 

to 4035.330, edit the End Invert Elevation to 4036.336, click OK. 

 

Step 11: Select a structure, select a pipe, right click and select Select Similar, right click again and 

select Object Viewer. 
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Step 12: In the Object Viewer application window, select Shades of Gray for the Visual Style, select SE 

Isometric for the View Control, close Object Viewer. 

Step 13: Save the drawing. 

  

12 
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Editing Pipe Networks 

Once a pipe network or networks are created, there are several ways to edit and refine them. The pipe 

network layout tools, pipe network vista and using grips in both plan and profile views. Individual parts and 

structures can be edited within their properties dialog box as well.  

Splitting Pipe Networks 

Splitting a pipe network, creating multiple pipe networks from an existing single network, maybe necessary 

through the design process. Most of the part properties of the selected parts are not modified when splitting 

a pipe network. Part properties such as the referenced surface, referenced alignment and labeling, remain 

unchanged when the pipe network is split. The only part property that changes is the pipe network that the 

parts are associated with. 

Creating a Proposed and Existing Network 

Step 1: Navigate to TOOLSPACE > Prospector panel, expand Pipe Networks, expand Networks, right 

click Drainage, select Network Properties. 

Step 2: In the Pipe Network Properties dialog box, select 

Information tab, rename the network from Drainage to 

Existing Drainage, select OK. 

 

 

Step 3: Select the pipe and structure that was created 

previously, select Split Network from the contextual 

ribbon. 

Step 4: From the command line, select Create new pipe network.  

1 
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Step 5: In the Create Pipe Network dialog box, change the following parameters, select OK. 

Network Name: Proposed Drainage 

Network parts list: MDT Drainage Parts 

Surface name: 8684000DIEFF001 

Alignment name: Mainline 

Step 6: Navigate to TOOLSPACE > Prospector panel, expand Pipe Networks, expand Networks, 

right click Proposed Drainage, select Zoom to. 

  

5 

Click OK 
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Merging Pipe Networks 

Merging pipe networks, the opposite of splitting them, takes multiple pipe networks and creates a single 

pipe network from the pipes and structures. When using an analysis tool like Autodesk Storm and Sanitary 

Analysis (SSA) it may be necessary to merge existing and proposed pipe networks into a single network to 

perform the analysis.  

Creating a single Pipe Network from multiple 

Step 1: Zoom to the existing surveyed culvert located southerly of the pipe culvert that was created in 

the previous steps. 

Step 2: Navigate to Home Tab > Create Design panel > Pipe Network, select 

Create Pipe Network from Object. 

Step 3: Select Xref from the command line, select the blue line representing the existing culvert, select 

Enter to accept the Northeast flow direction. 

 

2 

1 
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Step 4: Make the following parameter changes, click OK. 

 Network name: Ex Culvert 

 Network parts list: MDT Drainage Parts 

 Pipe to create: 48 RCP 

 Structure to create: 118 x 46 x 36 inch Concrete Rectangular 

Box Culvert Headwall 

 Surface name: 8684000DIEFF001 

 Alignment name: Mainline 

 Use vertex elevations: check 

 Vertex Elevation Reference: Invert 

Step 5: Select the northerly headwall, rotate the headwall using the grip to align with the culvert.  

Step 6: With the headwall still selected, navigate to the Modify panel, select Edit Pipe Network. 

4 

Click OK 
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Step 7: On the Network Layout Tools, select the Delete Pipe Network Object tool, select the southerly 

headwall, press Enter to complete the command. 

Step 8: Navigate to the Modify tab > Design panel, select Pipe Network. 

Step 9: Navigate to the Modify panel, select Merge 

Networks. 

Step 10: In the Select pipe network to be merged into another network dialog box, select EX Culvert, 

click OK. 

Step 11: In the Select destination pipe network, 

select Existing Drainage, click OK. 

7 
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Click OK 
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Click OK 

11 



User Guide Pipe Networks 

 

 

MDT Internal Use Only 85 

Step 12: Navigate to TOOLSPACE > Prospector tab, expand Pipe Networks, expand Networks, 

verify only Existing Drainage and Proposed Drainage are listed. 

Disconnecting and Reconnecting Pipe Networks 

Disconnecting and reconnecting pipe network parts is a simple task in Civil 3D. When disconnecting a part, 

the disconnected part can then be moved in the drawing without moving parts that were attached to it. Even 

though a part may be disconnected from the other parts in the same pipe network, the disconnected part 

still belongs to the same pipe network. Once disconnected a part can be easily reconnected using the right-

click menu. 

How to Disconnect and Reconnect Networks 

Step 1: Select the headwall, right click and select Disconnect from part, select the culvert pipe when 

prompt to Select Connect Part. 

Step 2: Select the culvert pipe, move the culvert pipe away from the headwall using the square grip. 

12 
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Step 3: With the culvert pipe still selected, right click and select Connect to part, select the headwall 

when prompt to Select Network Structure. The culvert pipe is reconnected to the headwall. 

Renaming Pipe Networks 

Using the Rename Parts command allows for rename one, all, or a sequence of connected parts within a 

pipe network. Using this command, a name template can be applied to the new part names as well. 

Editing network parts names 

Step 1: Navigate to TOOLSPACE > Prospector tab, expand Pipe Networks, expand Networks, expand 

Existing Drainage, select Pipes. Notice the list of pipes and names at the bottom of the 

TOOLSPACE. 

Step 2: Select both pipes by holding the Ctrl button while selecting. 

Step 3: Right click on the selected pipes and select Select. 

Step 4: Navigate to the Modify panel on the Pipe Network: Existing 

Drainage contextual ribbon, select the arrow next to Modify, 

select Rename Parts. 

  

3 
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Step 5: On the Rename Pipe Network Parts dialog box, 

make the following parameter changes, click OK. 

 Rename structures: Uncheck 

 Rename pipe: Check 

 Name: Existing Culvert - <[Next Counter(CP)]> 

 Starting number: 1 

 Name conflict options: Rename existing parts 

Step 6: Navigate to TOOLSPACE > Prospector tab, 

expand Pipe Networks, expand Networks, 

expand Existing Drainage, select Pipes. Notice 

the list of pipes and names at the bottom of the 

TOOLSPACE have been updated. 

 

Step 7: Press Esc to deselect any network objects and to clear the command line. 

Display Pipe Networks 

Pipe network parts, or entire pipe networks, can be displayed in profile views and section views. Making 

changes to the pipe network in plan view, such as moving, swapping, deleting, or resizing parts, those 

changes are reflected when the parts are dynamically displayed in profile view and section view.  

Drawing Network Parts in Profile views 

Step 1: Navigate to Home tab > Profile & Section Views panel, select Profile View, select Create 

Profile View. 

5 

Click OK 
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Step 2: On the Create profile View wizard, accept the defaults for General, Station Range and Profile 

View Height, select Profile Display Options link, change the Style to PLN Design Profile, 

change the Labels to PLN P-P-Mainline, click Create Profile View. 

Step 3: Select a point on the screen to place the Profile View when prompted. 

  

2 

Click Create Profile View 
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Step 4: Navigate to TOOLSPACE > Prospector tab, expand Pipe Networks, expand Networks, 

expand Existing Drainage, select Pipes, right click on Existing Culvert – (1) from the list 

view, select Select. 

• The naming of the pipes could be different than what is shown here. Verify the selected pipe is 

the 48”pipe crossing the roadway, and not the 36” pipe. 

Step 5: Navigate to Network Tools panel on the contextual ribbon, select Draw Parts in 

Profile. 

Step 6: Select the Mainline Profile View when prompted, press Esc to end the 

command. 

Editing Network Parts Profile View Display 

Step 1: Select the Mainline Profile View, right click and select 

Profile View Properties. 

 
The pipe is drawn in the profile view utilizing the pipe style. A style override is needed to properly 

display the pipe in the profile view. 
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Step 2: On the Profile View Properties dialog box, select Pipe Network tab, select Style Override for 

Existing Culvert – 1, select Pipe Crossing Pipe (Storm) from the Pick Pipe Style dialog box, 

click OK on the Pick Pipe Style, click OK on the Profile View Properties dialog box. 

 

  

2 
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Generating Labels, Tables and Reports 

Like most Civil 3D objects, pipe networks can be dynamically labeled. Labels can be added to pipe network 

parts either when created or after being created. Labels can be added to single parts and multiple parts in 

plan, profile, and section views. Tables can also be created for pipe network parts. Pipe tables can include 

data such as pipe shape, size, length, slope, start and end stations, or almost any pipe property. The Civil 

3D Reports Manager can be leveraged to generate reports for pipes, pipes and structures, structures, and 

structures in a CSV format. The Report settings can be customized to generate the preferred report format 

and data. 

Labeling Pipe Network Parts 

Step 1: Navigate to TOOLSPACE > Prospector tab, expand 

Pipe Networks, expand Networks, expand Existing 

Drainage, select Pipes, right click on Existing Culvert – (1) 

from the list view, select Zoom to. 

• The naming of the pipes could be different than what is shown here. Verify the selected pipe is 

the 48”pipe crossing the roadway, and not the 36” pipe. 

Step 2: Select Existing Culvert – (1), navigate to Labels & Tables panel, select Add Network Labels. 

Step 3: On the Add Labels dialog box, select Single Part Plan for the Label type, select MDT Pipe Label 

for the Pipe label style, click Add. 
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Step 4: Press Esc to deselect all objects, select the pipe label, drag the pipe label using the square grip. 

Step 5: Click the circle grip to reset the label position, press 

Esc to deselect the pipe label. 

Step 6: On the Add Labels dialog box, select Single Part Plan 

for the Label type, select MDT Structure Label for the 

Structure label style, click Add. 
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Click Add 
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Step 7: Select the existing Flared End Section when prompted to Select structure or pipe. 

Step 8: Select the structure label, drag the structure label using the square 

grip. 

Creating a Pipe Network Table 

Step 1: Select the 48” Existing Culvert – (1) pipe, navigate to Labels & 

Tables panel, select Add Table, select Add Pipe. 

Step 2: On the Pipe table Creation dialog box, select Name Size Length Slope Material from the Table 

style, click OK. 

 

Step 3: When prompted to Select upper left corner, select a 

point in the drawing to insert the table. 
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Producing Pipe Network Reports 

Step 1: Navigate to TOOLSPACE > Toolbox tab, expand Reports Manager, expand Pipes, double 

click on Pipes. 

Step 2: On the Export to XML Report dialog box, click OK. 

Step 3: In the Save As dialog box, browse to C:\mdtapps\Autodesk_Training\202-C3D Fundamentals ll, 

click Save. 

Step 4: After viewing the report, close the web browser, save and close the drawing. 
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Project Explorer 

Project Explorer is an all-in-one hub for managing the contents of and extracting information from Civil 

3D models. It helps users to review, validate, report, export and edit models. Project Explorer helps users 

to gain a better understanding of their design, and to control the distribution of geometric information more 

efficiently. Project Explorer functions as a central hub for managing and easily accessing project data. Here 

are a few of the ways you can leverage Project Explorer to streamline project workflows. 

• Project Explorer allows users to simplify access and navigation to important project data 

• Simplify project data navigation, review, and design model editing. 

• More easily discover and evaluate design criteria warnings to help meet design standards. 

• Efficiently generate custom reports and tables that help meet delivery requirements. 

Project Explorer is located on the Home tab of the ribbon >  

User Interface (UI) and Navigation 

Project Explorer Window 

The modeless live operation of the Project Explorer window allows users to work both in C3D and Project 

Explorer, moving freely between both. The Project Explorer window displays live geometric project data 

from the active Civil 3D model. When project data is modified or added to the model, the content displayed 

in the Project Explorer window will automatically update. To offer greater control over how project data 

displays in the window, you can customize the window. By selecting an element in the Project Explorer 

window and pressing the CTRL button, you can highlight the element in the C3D workspace. To offer 

greater control over how project data displays in the window, a template-based approach is used to 

customize the window. 

Using dynamic profile and section views in Project Explorer can aid in the design and review process more 

efficiently. Additionally, support for multiple object editing can help to streamline the process of making 

multiple design changes in Civil3D. 

Step 1: Using your preferred method > Navigate to and open 8684000RDCOR001-PROJEXP.dwg 

• C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II\Working 

Step 2: Save-as and Name the drawing: 8684000RDCOR001-PROJEXP-USER INITIALS.dwg 

• C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II\Working 

Step 3: Navigate to the Home tab > Select Project Explorer.  

 
The Project Explorer window will remain open until closed by the user or C3D is closed. 

3 

Select OK if prompted 
to use Online Maps. 
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Before getting started with any model edits, let’s first review the Project Explorer window to become 

familiar with the User Interface (UI).  

Depending on the active object type, the main layout is generally divided into two or three panes. 

 

  

A. Project Explorer window. E. Profile or Section View pane. 

B. Object Category Type tabs. F. Pane Layouts (used to control layout of individual panes). 

C. Object List pane. G. Preferences (controls color, scaling, fonts, etc). 

D. Sub-object Lists pane. H. Layout Options (control both data displayed and report layout). 

 
Object Category Type: Number in ( ) indicates number of individual objects in model. 

 
The middle mouse button can be used for panning and scrolling in the Profile or Section View 

pane same as in Civil 3D. 

Columns can be sorted and repositioned as desired. 

• Click-n-Drag on column header to reposition. 

• Click on column header to sort data per column data. 

Multiple items (rows) can be selected using left-click+Shift or left-click+Ctrl. 
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Preferences and Layout Options 

The Project Explorer Window and related layout panes are fully customizable. The available customization 

options are divided into two types, Preferences and Layout Options. Access to the settings and parameters 

for both are in the lower left corner of the main Project Explorer window. 

Step 1: From the Project Explorer window > Select Preferences… 

Step 2: From the Project Explorer Preferences dialog box, review the available settings. 

Parameters in the Preferences dialog box control the graphical display of all user interface items not directly 

associated with the layout of columns and the generation of reports. 

A. Preference controls for creating new, opening exiting, and saving user set preferences. 

B. Tabs for General and Object specific preferences. 

C. Parameters of current selected tab that can be adjusted. 

D. Restore Defaults > resets all parameters to default settings.  

Step 3: Click Cancel. 

Step 4: From the Project Explorer window > Select Layout… 

Step 5: From the Project Explorer Layout Options dialog box, review the available settings. 
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Parameters in the Layout Options dialog box provide control for the Project Explorer window and control 

for reports. The parameters for the Project Explorer window and reports work independently from the other 

allowing specific parameters to be set for the working display, and reports. Furthermore, parameters can 

be set for each type of object. 

Step 6: Click Cancel. 

Reviewing and Editing Object Data 

Changes and edits to a C3D model can be made directly through the Project Explorer window.  

• Values with the text color purple and white background are editable values. 

• Values with the text color red and shield are flagged as a warning and or in violation. 

• Double-click on any editable parameter to revise the value. 

• Right-click a selection of objects will provide access to a limited range of editable parameters. 

• Use of the available dedicated tools specific to the object selected, such as edit Pipe Run. 

Reviewing Object Data 

Step 1: From the Project Explorer window > Select the Alignments object tab. 

A. Preference controls for creating new, opening exiting, and saving Layout Styles. 

B. Tabs for General and Object specific preferences. 

C. Parameters of current selected tab that can be adjusted. 

D. Restore Defaults > resets all parameters to default settings.  

C 
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Step 2: From the Project Explorer window > Object List pane > Select Culvert Crossing (294+44.05). 

Step 3: From the Project Explorer window > Object List pane > Select the Surface at Crossing profile. 

Step 4: From the Project Explorer window > Profile View pane > See the highlighted profile. 

Step 5: From the Project Explorer window > Sub-object Lists pane > Select any Calculated Station.  

 
Alignment Objects are not displayed in the Profile / Section View pane. Selected Alignment Objects 

only display the alignment stationing. 
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Step 6: From the Project Explorer window > Profile View pane > See the highlighted station.  

Step 7: From the Project Explorer window > Sub-object Lists pane, with any Calculated Station selected 

> Press Ctrl key > While pressing the Ctrl key > From Model space > See the highlighted station. 

Step 8: From the Project Explorer window > Object List pane > Select the Mainline alignment. 

Step 9: From the Project Explorer window > Sub-object Lists pane > Select the Alignment Entities tab.  

Step 10: From the Alignment Entities tab > Review the Entity Index column. 

a. Notice some Alignment Entities are displayed in red with a warning symbol. 

b. Hover over Entity 1 > See the Warning Pop-up > Sub-Entity 1 (Line).  

Step 11: From the Alignment Entities tab > Sub-object Lists pane > Select Entity 1 > Press Ctrl key. 

a. While pressing the Ctrl key > From Model space > See the highlighted Alignment Entity. 

(The right-click menu can be used to Zoom or Pan to the selected entity.) 
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Editing Object Data 

Not only can a C3D object be viewed in Project Explorer, but some parameters can also be edited. The 

edits in Project Explorer will automatically update the Civil 3D objects in the drawing model. 

Step 1: From the Project Explorer window > Select the Pipe Networks object tab.  

Step 2: From the Project Explorer window > Object List pane > Right-click on E US-HWY 12 Drainage. 

a. Select Zoom to (AutoCAD Viewport).  

Step 3: From Model space > See the E US-HWY 12 Drainage pipe network. 

a. With the Pipe Network object still selected in the Object List pane > Press the Ctrl key >  

From Model space > See the highlighted Pipe Network objects. 

 Project Explorer Keyboard Shortcuts 

Z Zoom to selected object. 

P Pan to selected object. 

S Select the selected object. 

C Clear or de-select current selection. 

A (or E) Open C3D Properties for selected object. 

CTRL Temporarily highlights selected object. 

CTRL A Select all items in list. 

CTRL C Copy selected list items to clipboard. 

2a 
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Step 4: From the Project Explorer window > Sub-object Lists pane > Select the Pipes tab.  

Step 5: From the Profile View pane > See the highlighted pipe and existing Pipe Run Slope. 

Step 6: Using the available tools above the Profile View pane > Select Edit Pipe Run…  

Step 7: From the Edit Pipe Run Slope and Elevations dialog box > Revise the Pipe Run Slope to -2.00 

Step 8: Click OK.  

Step 9: From the Project Explorer window > Profile View pane & Sub-Object Lists pane >  

See the highlighted pipe and updated Pipe Run Slope. 
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Generating Tables and Reports 

Tables and Reports 

Project Explorer can quickly generate tables, reports, and spreadsheets from project data. The workflow is 

fully template driven using Layout Styles, Table Styles, and Report Styles. The Quick Report Window can 

be used to generate reports and spreadsheets.  

Quick vs. Object Sets 

It is important to understand the difference between generating a Quick report and or table verses 

generating a report and or table using Object Sets. 

• Quick =  

Static operation capturing current state of model object. Not dynamically linked to C3Dobject. 

• Object Sets =  

Dynamic operation providing real time updates to tables when C3D source object geometry is 

adjusted. Provides more user control over content, scope, and layout of tables and reports. Tables 

and reports can be generated quickly using predefined settings from the Object Set. The is no limit 

to the number of Object Sets that can be saved. Any Object Set created follows the drawing file, 

so anyone with access to the drawing and Project Explorer can utilize the same Object Set. 

Tables using Quick Report 

Step 1: From the Project Explorer window > Select the Pipe Networks object tab.  

Step 2: From the Project Explorer window > Object Lists pane > Right-click on E US-HWY 12 Drainage. 

a. Select Quick Report to AutoCAD Table (Pipes List)…  
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Step 3: From the Create AutoCAD Table dialog box > Accept all default settings: 

• Title Cell Template = {Object_Name} 

• Layout Style for AutoCAD Table = Use Layout of Project Explorer Window. 

• Use Object Table(s) = CHECKED 

• Use Sub-Object Table(s) = CHECKED 

• Table Style for AutoCAD Table = Use Project Explorer Table Style. 

Step 4: Click OK 

Step 5: When prompted > Specify an insertion point in Model space for the table. 

Step 6: Press ESC to end the table placement command. 

 Step 7: From Model space > See and review the Quick table. 

Step 8: Save the drawing . 

  

 
When generating an AutoCAD table, there 

two key parameters that are needed to 

define the layout and format of the created 

table. 

Layout Style: Required to define the layout, 

format, heading name, and what columns 

and values are visible. 

Table Style: Required to define the table 

border color, font type and size, cell margins 

and general visual style for table.  

Click OK 4 
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Tables using Object Sets 

Step 1: From the Project Explorer window > Select the Object Sets tab.  

Step 2: From the Object Sets tab > Create a new Object Set > Select New Object Set… 

Step 3: From the Create Object Set dialog box > Set and verify the following parameters: 

a. Object Set Name = Culvert Pipe Crossing 

b. Object Set Description = Object set used for Culvert Pipe Crossing 

c. Object Set Action = Export to AutoCAD Table(s) in MODEL Space 

d. Object Set Action Type = Dynamic 

e. Layout Style = Use Layout of Project Explorer Window 

f. From the AutoCAD Table Output Options tab > Select Pick insertion point 
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g. When prompted > Select an insertion point in Model space. 

h. Title Cell Text Template = {Object_Name} 

i. Table Style = Use Default Table Style of Objects Sets 

Step 4: Click OK. 

Step 5: From the Object Sets tab > Object Lists pane > Select  Add/Remove Objects to/from 

Object Set. 

Step 6: From the Add Object(s) to Object Set dialog box > Select the Pipe Networks tab. 

Step 7: Check the E US-HWY 12 Drainage Pipe Network. 

Step 8: Click OK.  

Step 9: From the Object Sets tab > Object Lists pane > Double left-click on Structures List. 

a. From the Select Sub-Object Type dialog box > Select Pipes List from the available types. 

b. Click OK. 

Step 10: From Model space > See and review the table inserted in the drawing. 

Step 11: Save the drawing . 
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Step 12: From the Project Explorer window > Object Sets tab > Double left-click on the Culvert Pipe 

Crossing Object Set to open the Edit Object Set dialog box. 

Step 13: From the Edit Object Set dialog box > Layout Style options > Select Use Specific Layout Style. 

a. Click Edit Style… 

Step 14: From the Layout Options dialog box > Select the Pipe Networks tab. 

a. Set the Pipe Network Column Chooser to Set Column Layout for Pipes. 

b. Select the Clear All box to un-check the current Column Label selection.  

c. Check the following Column Labels: 

• Pipe Name 

• Description 

• Part Size Name  

• Start Structure 

• Start Invert 

• 2D Length (Center to Center) 

• Slope 

• End Structure 

• End Invert 

d. Using the hierarchy arrow tools > Reorder the Column Labels to match the list above. 

 Column Labels can be re-ordered using the hierarchy 

arrow tools found on the right side of the Layout 

Options dialog box. 
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Step 15: Click OK.  

Step 16: When prompted from the Save Layout Style As dialog box > Navigate to: 

a. C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II\Config\Project Explorer\Layout Styles 

b. Enter File Name = Pipe Layout  

c. Click Save.  

Step 17: From the Edit Object Set dialog box > Table Style options > Select Use Specific Table Style. 

a. Click Edit Style… 

Step 18: From the Table Options dialog box > Set and verify the following parameters: 
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Click Edit Style… 17a 
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Table Options 

a. Use Background Colors = Unchecked 

b. Show Borders = Checked 

c. Border Color = (EX: Blue) 

Title Row Options 

d. Title Row Text Color = (EX: Red) 

e. Title Row Font = Arial 

f. Force text in title rows to UPPERCASE = Checked 

Data Row Options 

g. Data Row Text Color = (EX: Red) 

h. Data Row Font = Arial 

Header Row Options 

i. Header Row Text Color: (EX: Red) 

j. Header Row Font = Arial 

*Leave ALL other defaults “As-Is” 

Step 19: Click OK.  

Step 20: When prompted from the Save Table Style As dialog box > Navigate to: 

a. C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II\Config\Project Explorer\Table Styles 

b. Enter File Name = Pipe Table 

c. Click Save.  

Step 21: From the Edit Object Set dialog box > Click OK.  

  

Click OK 21 
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Step 22: From the Project Explorer > Object Sets tab > Object Lists pane > Double left-click on Yes. 

a. From the Object Set Item Output Options dialog box > Uncheck Use Object Table? 

Step 23: Click OK. 

Step 24: From Model space > See and review the updated table.  

 

Reports using Object Sets 

Step 1: From the Project Explorer window > Object Sets tab > Right-click on the Culvert Pipe Crossing 

Object Set.  

a. From the pop-up menu > Select Copy. 

b. With the Object Set still selected > Right-click > From the pop-up menu > Select Paste. 

 Project Explorer must be open for table updates to occur.  
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Step 2: Right-click on the pasted Object Set > From the pop-up menu > Select Object Set Properties… 

Step 3: From the Create Object Set dialog box > Set and verify the following parameters: 

a. Object Set Name = Culvert Pipe Crossing - Report 

b. Object Set Description = Object set used for Culvert Pipe Crossing reports. 

c. Object Set Action = Report to XLSX (*.xlsx) 

d. Layout Style = Use Specific Layout Style 

• Pipe Layout.xmpt (previously created for use with tables.) 

From the File Output Options tab: 

e. Output Path = C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II\Working 

f. Report Style = Use Specific Report Style 

Step 4: Click Edit Style… 

Step 5: From the Report Options dialog box > Explore the options and parameters that can be set and 

adjusted on each of the available tabs.  
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Step 6: After setting the options and parameters > Click OK.  

Step 7: When prompted from the Save Table Style As dialog box > Navigate to: 

a. C:\mdtapps\Autodesk_Training\202-C3D Fundamentals II\Config\Project Explorer\Report Styles 

b. Enter File Name = Pipe Report 

c. Click Save.  

Click OK 6 
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Step 8: From the Project Explorer > Edit Object Set dialog box > Click OK.     

Step 9: From the Project Explorer window > Object Sets tab > Select Culvert Pipe Crossing – Report. 

Step 10: From the Project Explorer window > Select Run Selected Action.  

Step 11: When prompted > Do you wish to open this file now? > Click Yes. 

Step 12: The report is generated and opens > Review the generated report (EX: .xlsx). 

Step 13: Save the drawing . 

 Reports for other Civil 3D objects can be generated 

following the same steps previously outlined in the 

Reports using Object Sets section. 
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