Reference Documentation and Program Operation Notes

STAR*NET Manual Page 87 and STAR*NET-LEV Manual Page 38
The “.LWEIGHT” inline option:

The documentation states that when the “.LWEIGHT” inline is entered without parameters
(as shown in the example on that page), the weighting scheme for leveling will revert back to
the original default set in the Project Options.

This is not true in the current V6.0.24 release but will be in the next release. In the current
release, to change the weighting by inline option, parameters must always be entered. The
weighting, however, will automatically revert to the original defaults at the end of data file as
indicated in the documentation.

STAR*NET Manual Page 29 and STAR*NET-LEV Manual Page 22
The “Coordinate Changes from Entered Provisionals” Listing Option:

This listing option is not currently available in the current releases when running LEV only
adjustments. It is planned for the next release.

STAR*NET Manual Page 23 and STAR*NET-LEV Manual Page 19
The Instrument settings for Leveling Standard Error when Sections are set as “Turns:”

We recently discovered that the calculation for total survey line standard error was incorrect
whenever units are set for feet and sections are defined as turns. The calculation, however, is
correct when units are set to meters. The calculation is also correct whenever you use the
“ LWEIGHT” inline option described in Chapter 4, “Options.”

Since we rarely hear of leveling networks being weighted by turns any more, we decided to
wait until the next release to make this correction. If you have questions about this, please
call us at technical support or email Starplus@earthlink.net.
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1. LICENSE

STARPLUS SOFTWARE, INC. grants you license to use this software on a single
machine at a time. The software may be copied to multiple machines and the hardware
security key moved between machines as needed. But unless otherwise licensed, you may
not network the software or otherwise use it on more than one computer or computer
terminal at a time.

The software is owned by STARPLUS SOFTWARE, INC. and is protected by United
States copyright laws and international treaty provisions. Therefore you must treat the
software like any other copyrighted material (e.g., a book or musical recording) except
that you may make copies of the software solely for backup purposes. All copies made
must include the copyright notice. The software is for your exclusive use and may not be
rented, leased or sublicensed to another party.

2. WARRANTY

With respect to the physical dstribution media, STARPLUS SOFTWARE, INC. warrants
the same to be free of defects in materials and workmanship for a period of 30 days from
the date of purchase. In the event of notification within the warranty period of defects in
material or workmanship, STARPLUS SOFTWARE, INC. will replace the defective
media. The remedy for breach of this warranty shall be limited to replacement and shall
not encompass any other damages, including but not limited to loss of profit, special,
incidental, consequential, or other similar claims.

STARPLUS SOFTWARE, INC. specifically disclaims all other warranties, expressed or
implied, including but not limited to, implied warranties of merchantability and fitness
for a particular purpose, with respect to software and documentation provided. This
warranty gives you specific legal rights. You may have others, which will vary from state
to state.

In no event will STARPLUS SOFTWARE, INC. be liable for any damages whatsoever
(including, without limitation, damages for loss of business profits, business interruption,
loss of information, or other pecuniary loss) arising out of the use or inability to use this
software product even if STARPLUS SOFTWARE, INC. has been advised of the
possibility of such damages. Because some states do not allow the exclusion or limitation
of liability for consequential or incidental damages, the above limitation may not apply to
you.

3. GOVERNING LAW

This license statement shall be construed, interpreted and governed by the laws of the
state of California.

Print/Version/August 2002
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CHAPTER 1 OVERVIEW

The STAR*NET software suite handles general purpose, rigorous least squares analysis
and adjustments of 2D, 3D and 1D land survey networks.

This reference manual is a much-shortened version of the full STAR*NET manual and
documents features mainly relevant to the STAR*NET-LEV edition. Most of the
information relating to 2D and 3D options and data types has been removed. Some
sections in this manual, however, do reference or illustrate 2D or 3D information but
these references are usually general in nature and relate to the operation of the program
for all types of networks.

Four STAR*NET editions are available to fit the particular needs of the user:

» Standard Edition — Handles 2D/3D survey networks. Differential leveling data may
also be combined in a 3D adjustment. This edition includes all the base features
which make STAR*NET so useful to surveyors including an instrument library
facility, points reformatter, grid-to-ground coordinates converter, DXEF transfer tool,
network graphics display with full zooming, point and connection inquiry from the
graphics display, and much more.

= PLUS Edition — Adds a separate 1D differential leveling network adjustment facility
to all features of the Standard Edition.

» PRO Edition — This high-end edition adds GPS handling and geoid/deflection
modeling capabilities to all features of the PLUS Edition. It includes a vector
importer that supports most popular baseline formats. Special GPS options allow
scaling of vector weighs and application of centering errors separately in horizontal
and vertical directions. Combining conventional, leveling and GPS is made easy!

= LEV Edition — This subset edition handles differential leveling network adjustments,
a perfect low-cost solution for consultants requiring this this type of adjustment only.

One of the main features of STAR*NET is the capacity to weight all input data both
independently or by category. This means that accurately known measurements can be
given more weight in the adjustment than those measurements known to be less accurate.
Completely unknown quantities, such as the coordinates of a new station, may be given a
special code indicating that they are “FREE” in the adjustment. The user can “FIX” other
data with a code so that they receive no correction. The ability to control the weighting of
data provides the user with a powerful adjustment tool.

The user may select a number of options to determine the type of adjustment to be
performed. All option selections and program commands are made through a dialog
interface, making program operation simple, even for casual users.
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Chapter 2 INSTALLATION

2.1 Overview

This chapter explains the simple steps that are required to install STAR*NET package. If
you do have problems, you can obtain assistance by contacting:

STARPLUS SOFTWARE, INC.

460 Boulevard Way, 2™ Floor

Oakland, CA 94610

TEL: 510-653-4836 (Technical Support)
FAX: 510-653-2727

EMAIL: starplus@earthlink.net

2.2 Installing STAR*NET

First, if you are installing on an NT-based system, be sure you have administrator
privileges because the installation may upgrade out-of-date system files and add drivers.

Insert the supplied install CD media into the appropriate drive.
1. From the Windows taskbar, select Start>Run. The Run windows appears.

2. In the Open field, type “D:\SETUP”, substituting the actual letter of the CD drive
you are using on your system. Select OK.

3. Follow the installer instructions. Note that you can accept the default destination
directory “C:\Program Files\Starplus\StarNet” or choose a different directory. To
designate a different installation destination, select Browse, and then in the directory
dialog, choose a path and directory name of your choice.

If you choose to designate a different installation destination, we encourage you to
create a separate directory for the STAR*NET program. To eliminate the possibility
of conflicts, do not use a directory containing other programs or demos from Starplus
Software or programs from other companies.

4. Once the installation is complete, the program is ready to run. See the next section for
starting the STAR*¥NET program.

After installing, we encourage you to review “A Tour of the STAR*NET Package” in
Appendix-A for a detailed overview of program use. We highly recommend you run the
supplied example project before reading the main manual in detail.

Chapter 3 provides an overview of running a complete adjustment, while subsequent
chapters provide detailed information on the different aspects of data preparation,
analysis of output, and graphical display of your adjustment.



Chapter 2 Installation

2.3 Starting the STAR*NET Program

1. First, attach the supplied license Security Key (Dongle) to one of your parallel ports.
The dongle should co-exist with other dongles you may have on your system. You
can also run STAR*NET without the dongle, and it will run in a demo mode. In
demo mode, all features, including those of the “Professional” edition, will function,
but all the “Run” functions will be limited to 10 network stations.

2. To run STAR*NET, press the Start menu, select Programs>Starplus, and then click
the “StarNet” program selection to start the program. The program will run as the
Standard, PLUS, PRO or LEV edition depending on which you purchased.

To run STAR*NET from an icon on the desktop, which is much more convenient, you
must first place its icon on the desktop. To do this, follow the same steps as shown above,
except do not click the StarNet program selection. Instead, right-click the StarNet
program item and drag it to the desktop. When you drop it on the desktop, choose the
“Create Shortcut Here” selection offered. Now all you have to do is double click this icon
to start the STAR*NET program.

2.4 Setting a Start-In Folder

When you open a new or existing project, you enter your project name in a standard file
selection dialog. This dialog initially opens in the “Start-In Folder.” When STAR*NET is
first installed, the Start-In Folder is automatically set to a folder named “Examples”
which is a subdirectory of the install directory. This makes it easy to run the example
projects supplied with the installation.

However, when you begin working with your own projects, you will want to reset the
default Start-In Folder to a more convenient directory so you can easily get to your own
project files with a minimum of browsing:

1. Choose File>Set Start-In Folder.

2. In the dialog, press Browse and select your desired start-in folder.

2.5 Setting an Editor

STAR*NET uses text files as data. Therefore to enter or modify data, you will be using a
text editor. The Windows Notepad editor is assigned as the default editor, but you can
redefine the default editor be to your own favorite text editor:

1. Choose File>Set Editor.

2. In the dialog, type the name of your editor including its full path in the field, or press
Browse to select the editor program using standard Windows file dialogs.
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2.6 Text Page and Plot Page Setups

The “Text Page Setup” item in the File menu allows you to define settings for how you
want printed pages (adjustment reports, coordinate listings, etc.) shown. You can define
the printer device, page size, orientation, margins, whether you want pages numbered,
and whether you want long lines (those longer than a page width) clipped or wrapped
around. Reasonable defaults are set by the program, but at some time you should review
and set any preferences you want changed.

The “Plot Page Setup” item in the File menu allows you to define settings for printing
graphical network plots. You can define the printer to use, sheet size and orientation. The
printer used for printing the plots does not have to be the same printer used for printing
listing reports. For example, if you have a plotting device attached directly to your
computer or attached via a network, you may select it assuming your computer has the
drivers required to operate this device.

2.7 Set Run Type

The “Set Run Type” item in the File menu brings up the dialog shown below.

The Run Type item is initially set to “Local Key Only” and this is the setting that you
will normally want. The security key license device delivered with your order is set to
run one of the STAR*NET editions, either Standard, PLUS, PRO or LEV. This setting
simply means that you want to run the edition defined by the key you have.

However, if you have a LEV edition key attached to your computer, for example, and
you borrow a PRO key from a colleague, you can leave your key on, add his PRO key,
set the Run Type in the dialog to “Pro” and run STAR*NET. The program will look for
the PRO key and run with the PRO edition features. Likewise, to run the Demo program
without removing your key, set the Run Type to “Demo” and run. Don’t forget to change
the setting back to “Local Key Only” for normal operation!

The “Network Key Server” field is inactive in this release and is reserved for a special
networked edition that may be released in the future.
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2.8 Files Used by STAR*NET

A few words should be said about the files used by the program, what their functions are
and where they are located.

The following are “system” files containing information that may be used by any project.
These files are located in the STAR*NET’s “System” directory, normally the same
directory you installed the STAR*NET program.

FILE DESCRIPTION
STAR6.DEF Default company option settings and company instrument library
items - created the first time STAR*NET is run
STAR6.FMT Output coordinate format styles - installed
STAR6.SPC State Plane Coordinate System constants - installed
STAR6.CUS Custom grid zone and linear units definitions - installed

The following are “project-related” files that contain input data, options and output. Input
data files must be created before an adjustment. Output files are created during the run
and take on the name of the project. For example, if you are working with a project
named “JOB”, output files will inherit that name as illustrated below.

FILE DESCRIPTION

JOB.DAT One or more input data files - the “DAT” extension is suggested
however other file names and extensions may be used

JOB.PRJ Project options and project instrument library items - created when
a project is first created

JOB.LST Output - adjustment listing

JOB.ERR Output - error listing - created when errors or warnings found

JOB.SBF Output - Star Binary File - adjusted information used for the

creation of plots, reformatted points and DXF export

By default, all files for a project are located in the same directory, normally called the
project folder. Data files may optionally be located elsewhere.
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2.9 The Registry

The STAR*NET program makes use of your computer’s registry to keep track of certain
default directories, files and options. The items saved in the registry are automatically
created and managed by the program.

The following describes some of the information stored there.

The location of the STAR*NET “system” directory, the directory containing the
system files described in the previous section.

The size and location of the main STAR*NET window, plus the size and location of
most sub-windows (i.e. the listing and plot windows) when the program was last

used. The windows will come up looking the same the next run.

The Text Editor and Start-in Directory items selected by you using dialogs accessed
from the Files menu.

The “Recent Projects” list appearing at the bottom of the Files menu.

Printer and Plotter device preferences.

When you install STAR*NET on another computer, these registry entries, of course, are
not copied and they will be reestablished by the program or reset by you.

If you reinstall the program (or install an updated version) over the original installation
on your computer, most of this registry information will be preserved. However you will
have to reset the “Start-in Directory” preferences in the Files menu.

Since this information is internally managed by STAR*NET, no documentation is given
to externally edit information in the registry.
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Chapter 3 USING STAR*NET

3.1 Overview

The list below summarizes the sequence of tasks you generally follow when creating a
project and performing adjustments with the STAR*NET program:

= Open a new project.

=  Set options describing your project.

» Create one or more input data files containing observations and control points.
= Run the adjustment.

= Iferrors or warnings were found, check the error listing for specific details.
» Edit your input data files to correct any errors found.

= Rerun the adjustment until there are no errors.

» Display the network graphically on your screen if possible.

» Review the output listing.

= Repeat the edit-run-review cycle as needed to get satisfactory results.

=  Print output listing, coordinate information and plot diagrams.

This chapter briefly describes the steps in running a typical STAR*NET adjustment.
Subsequent chapters will cover these topics and specialized features in detail.

3.2 How STAR*NET Handles Output Windows

Before going on, a word should be said about how window sizing and placement is
handled by STAR*NET. The size and location of the main program window as well as all
the output windows (listing window, plot window, etc.) are remembered! You have full
control of the size and location of these windows, and therefore you should set them the
way you feel is most convenient for you. When you exit the program and later restart it,
all the windows locate and size themselves the same way.

For example, the output listing file window is one that you will always view, therefore
you should make it as large as possible vertically and as wide as the output listing text.
Once you do this, it will stay this way. You should also choose a convenient size and
location for your plot window.

Note that you can leave output windows open while you edit data and rerun an
adjustment. Output windows (listings and plots) that are left open, will automatically

regenerate to show the newly adjusted results.

See Chapter 7, “Viewing and Printing Output” for more details on output windows.



Chapter 3 Using STAR*NET-LEV

3.3 The Menu System

STAR*NET - Trav3D -

STAR*NET menu items are arranged so that you work from left to right when creating
and running a project. First you use the File menu to open a new or existing project. Then
you set specific project Options, prepare one or more Input data files, Run your
adjustment, and finally, review the Output listing and plot.

The Tools menu item offers additional utilities described later in Chapter 9.

Buttons on the tool-bar provide quick access to the “most-used” menu functions:

a b ¢c d e

Create a New Project

Open an Existing Project

Set Project Options

Create or Edit Input Data Files (Right-click the button to edit current file)

Run an Adjustment (The “e” indicates that error propagation is to be performed)
List Errors (When indicated by a red “!” button)

View Output Listing File

View Network Plot

Preview a Text File or Plot (As it would appear printed)

Print a Text File or Plot

TR ER M S o

3.4 Opening a Project

Create a new project by choosing File>New Project or by pressing the New tool button.
Browse if required to a folder where you want to create the project. Enter the name of the
project (with no extension) and press Open. For example, if you enter the project name
SouthPark, a new SouthPark.prj file is created which will contain options for the your
new project.

Open an existing project by choosing File>Open Project, or by pressing the Open tool
button. Browse if required to the folder containing your project. Highlight your existing
project’s “PRJ” file and press Open — or simply double-click the existing “PRJ” file.

Alternately, if your project is one you recently worked with, open it by selecting its name
from the “recent projects™ list at the bottom of the File menu.

10
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3.5 Setting Project Options

STAR*NET saves a group of option settings for each project. These options define
characteristics of the survey network adjustment and are remembered for the duration of
the project. Choose Options>Project Options or press the Project Options tool button. A
tabbed dialog with eight categories is shown: Adjustment, General, Instrument,
Listing File, Other Files, Special, GPS and Modeling. Make changes to settings in one
or more of the option pages and press OK to save. The GPS and Modeling option pages
are active only in the Professional edition. (See “PRO” edition supplement.)

See Chapter 4, “Options” for complete details on setting project options.

3.6 Creating Input Data Files

Before you can run an adjustment, STAR*NET needs at least one input data file
containing your field observations. Choose Input>Data Files or press the Input Data
Files tool button. An Input Data File dialog appears and is used to specify what data files
to include in your adjustment. For a new project, a file name with your project name and
the “DAT” extension is automatically provided for your convenience. Data files are
standard text files that consist of lines of data conforming to STAR*NET’s rules. To edit
new survey observation data into this file, highlight its name in the dialog’s Data File
List, and press the Edit button.

Additional text files may be added to the project by pressing the Add button in the dialog
and then selecting an existing file or new file. When an adjustment is performed, each file
is read into memory in the order it appears in this dialog.

See Chapter 5, “Preparing Data” for details on using the Input Data Files dialog and a
complete description of input data formats.

3.7 Running an Adjustment

To run an adjustment for your project, choose Run>Adjustment, or press the Run
Adjustment tool button. STAR*NET loads your data file or files into memory, checks the
information, and then runs the adjustment. A “Processing Summary” window opens so
you can see the progress of the adjustment. When the processing finishes, a short
statistical summary is shown which should be inspected to judge the success of the
adjustment.

Besides the full adjustment, Data Check Only may be selected from the Run menu. It
reads and checks the data but does not perform an actual adjustment.

See Chapter 6, “Running Adjustments” for complete details on these Run features.

11
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3.8 Checking the Error File

When STAR*NET encounters problems during the adjustment run, it lists a message in
the “Processing Summary” Window that errors or warnings were detected. To view this
error file, choose Output>Errors, or press the Errors tool button. Based on what the
error file says, you may need to change one of the project options or edit an input data
file to correct a data error, and then rerun the adjustment.

The error file viewed below shows that typing errors were found in two lines of a data
file. In the first case, a non-numeric character was found in an elevation value. In the
second case, an invalid horizontal angle was found - the “minutes” value is too large.
Whenever possible, STAR*NET tries to show you where the error is by printing a line of
asterisks “******¥> gver to a bad character or to an illegal value.

! Iravl‘).érr
STAR*NET Error Log

[FILE: C:\Program Files\Starplus\StarNet\ Examples\Trav3D.Dat] '

ERROR [Line: 4] Missing or Invalid Coordinate Value
C A2 9866.00 7900.00 Sx98.89 L

LSS 2R AR EA R SRR R X R R LT

ERROR [Line: 15] Missing or Invalid Zenith Angle

T 4 101-39-39.6 1396.76 88-93-31.8 5.23/5.25
R RN R AN AR AR AR AR A RN RN AR RERNRRER

Processing Terminated Due to Errora.

For a listing of the common error and warning messages you might encounter, see
Appendix-C, “Additional Technical Information.”

3.9 Editing Input Data Files

To edit your data files, or to add additional data files, use the Input Data dialog as
described in “Creating Input Data Files” earlier in this section.

This dialog allows you edit any file by pressing the Edit button or by simply double-
clicking the file name. The dialog also allows you to add or remove data files from the
list, and to rearrange their order. You can also “uncheck” a data file which means it
remains part of the project, but will not be read for the next adjustment run,

Shortcut! To edit the currently highlighted file in the data files list without opening the

data files dialog, simply right-click the Input Data Files tool button. (The tool-tip for that
button indicates what file will be edited.)

12
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3.10 Reviewing the Output Listing

When you run an adjustment for a project, STAR*NET writes the results to an output
listing file. To review this file, choose Output>Listing, or press the Listing tool button.
The Output Listing window appears, and it includes its own tool buttons which allow you
to jump forward or backward in the file to view different sections.

Click the Listing Tree Index tool button, or right-click anywhere in the listing window
and a small “Listing Index Tree” window will appear which allows you to quickly
navigate to any section of the listing you are interested in seeing.

The output listing file contains many sections depending on the options set. You control
whether certain sections are included in the listing file by setting listing-content options
in the Project Options dialog discussed earlier.

3.11 Reviewing Other Output Files

As a result of an adjustment, other output files may be created depending on whether they
were requested in the Project Options settings.

For a run using the LEV edition, there is only one other output file that may be created:

» Coordinates (adjusted elevations)

3.12 Displaying the Network Graphically

If you entered horizontal “reference coordinates” for all stations in your level network
data, you may view a diagram of your adjusted network. Choose Output>Plot, or press
the Network Plot tool button.

Several tool buttons on the plot window allow you to zoom in and out, pan, center the
plot at a mouse click, find a point by giving its name, and inverse between given points.
You can also zoom by dragging a box round an area with your mouse. Right-click your
mouse on the plotting window to bring up a “Quick-Change” dialog where you can
quickly turn off or on plot items such as point names and markers.

Click on the plot window Options tool button to bring up a tabbed options dialog. Here

you can set many options including what items to show on the plot and the sizes of names
and markers.

13
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3.13 Printing Output Files and Plots

Any of the output files can be previewed and printed from within the program. For
example, the listing file is the main output document for your adjustment, and you will
usually want to print it when the project is adjusted to your satisfaction. To print any
output file, its window must be active.

Prior to actually printing output, choose File>Text Page Setup to select the output
printer and to set options such as margin sizes and page numbering. These settings are
saved as defaults and will be used for future STAR*NET printing until changed.

To preview how the printed output will look, choose File>Print Preview or press the
Print Preview tool button. To print the output, choose File>Print or press the Print tool
button. You can highlight any section of an output text file and print just that part.

When a Plot Window is active, you can also preview and print the plot diagram. Prior to
actually printing the plot, choose File>Plot Page Setup to select the output printer and
orientation. You can choose different printers for the text output (listings, etc.) and the
plot diagram output.

In your plot window, only display the items you want to see on your printed plot. For
example, if you do not want to see point names turn them off. Resize the window to
approximate the shape of your printed sheet. Zoom in or out to fill the image space to the
way you want the image to appear on your printed sheet.

Preview how the plot will look on a printed sheet by choosing File>Print Preview, or by
pressing the Print Preview tool button. Then actually print your network plot by choosing
File>Print, or by pressing the Print tool button.

See Chapter 7, “Viewing and Printing Output” for complete details on viewing output
listing files and network plots, and printing them.

14



Chapter 4 OPTIONS

4.1 Overview

| ic STAR*NET-LEY - LevelNet

STAR*NET maintains a list of settings for each job called “Project Options.” Most of
these options are settings and values that control how STAR*NET processes an
adjustment, and they are set by the user in dialogs discussed on the following pages.

STAR*NET stores the options for a project by creating a file named “PROJECT.PRJ,”
where “PROJECT” is the name of the project, for example, SouthPark.prj. All project
specific options are saved in this file. If you open an existing project at a later date, those
options automatically load and will remain in effect until you change them.

A special “default options” file named STAR6.DEF is located in the same directory you
installed STAR*NET. It is referred to as the Company options file. Initially, the
Company options file contains no default values and if you create a new project, the
program simply assigns built-in generic defaults as your project options. Therefore you
should set the Company options to settings typical of your projects as soon as possible
after installing the software. These option settings are then automatically applied to any
new project saving you the time of manually setting them yourself. Setting Company
options are discussed later in this chapter.

15
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4.2 Changing Project Options Using Options Dialogs

To set or change options for the current project, choose Options>Project, or press the
Project Options tool button.

An options dialog appears with eight tabbed dialog categories: Adjustment, General,
Instrument, Listing File, Other Files, Special, GPS and Modeling. The last two
dialogs, GPS and Modeling, are are used only with the “Professional” edition and are
described in the separate “PRO” manual supplement attached.

To review any option category, click the tab to open that specific options dialog. Make
necessary changes on one or more of the tabbed dialogs, and press OK to save your
changes. Or press Cancel to ignore all changes you have made.

As discussed on the previous page, when you save options, these settings will be stored in
a “PROJECT.PRJ” file having your project name. For example, if your project name is
SouthPark, the options are stored in a file named SouthPark.prj.

Specific details on settings for each of the option dialogs are described in detail on the
following pages.

4.3 Changing Project Options Using Inline Options

The options set in the project option dialogs described above assume the settings relate to
an entire project. However there are some settings related to observation data that may
not remain the same throughout an entire data file. Changes to option settings within the
data file are controlled by “Inline Options.”

For example, the setting for “leveling weight” in the options dialog has a single value.
But if you want to change this value one or more times for groups of observations in a
data file, insert a line like the one below to change value for observations following it:

.LWEIGHT 0.05

These “inline” options give you added flexibility — you are not tied down Jjust to option
settings in the option dialogs. “Inlines” allow you to change units anywhere in your data,
change weighting groups of observations and more.

Some of these inline options are mentioned in the descriptions of the project option
dialog settings on the following pages. Since these inline options are entered right in your
data files, their full descriptions along with examples are discussed in Chapter 5,
“Preparing Data,” in a section named “Using Inline Options.”
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4.4 Setting Project Options

To set options for your project, choose Options>Project, or press the Project Options
tool button. Use the tabbed dialog to change settings in the several categories and press
OK to save. The following pages describe all option settings in detail.

Adjustment Options

f Project Options

1.0000000000

lD oo

Option Group: Adjustment Type

For the STAR*NET-LEV edition, only the “Lev” setting is active. Only a few other
options on the dialog are relevant to level network adjustments — all other radio buttons
and fields are inactive and can not be selected or changed.

Option Group: Units

Select the linear units for your level network project from the dropdown selection list.
Adjustment results are always published using the selected units. By default, your input
data is assumed to be entered in these units.

An inline “.UNITS” option, however, may be used in your data to allow entry of

measurements in other units. Measurements entered in these alternate units are
automatically converted to the units set for the project during the run.
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General Options

The partially-shown General options dialog above includes “preference” type settings
that are general in nature that you will seldom need to change during the life of a job.

Again, for the LEV edition, very few options are relevant. Level network adjustments do
not require iterations - the solution is linear, so therefore convergence and maximum
iterations in the Adjustment Solutions section.

Option Group: Adjustment Solution

* Chi-Square Significance Level — A 5% level is the usual significance level preferred
by most statititions, but an alternate level may entered if you have some reason to do
so. The Chi-Square test is discussed in more detail in Chapter 8.

Option Group: Error Propagation

Here you indicate whether or not to perform error propagation, and what confidence level
to use. Error propagation is a separate function from the adjustment and it calculates
standard deviations and confidence (95% or whatever is selected) information for all
network station coordinates. If error propagation is not selected, standard deviations and
vertical confidence information is not computed and will not be in the listing,

The most commonly used confidence level is 95%. You can enter confidence level values
from 50% up to 99.999% depending on your project requirements,

Option Group: Input/Output Coordinate Order
If you plan to enter optional reference northing and easting coordinates in your data for

the sake of producing a network plot diagram, you can specify here the order they will be
entered, in North-East or East-North order.
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Instrument Options

D000

[T

Standard Errors

Standard errors are used in weighting your data. In this dialog, you enter standard error
values for most types of conventional and leveling observations used in an adjustment.
Your observations will default to these values unless explicit values are entered with the
observations in your data, or unless you use inline options to apply alternate standard
error values to your data.

For the STAR*NET-LEV edition, only the fields in the “Leveling” section are active as
shown above. For all other editions, Standard, PLUS and PRO, all fields are active.

For the LEV edition, linear units as shown in the dialog above, are based on the project
units set in the Adjustment Options. If you change the units settings in the Adjustment
Options dialog (from FeetUS to Meters for example), the standard error values and their
displayed units in the dialog shown above are automatically converted. You never have
to manually convert standard error values from one unit to another.

You should always set your standard error the values to those consistent with the actual
instruments and procedures used for your project! If you determine that your projects
normally use certain option values, you can change the startup defaults for new projects
by revising the values in the Company Options. See “Company Options™ later in this
chapter for details.
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Leveling Observations Group: Standard Error Settings

Weighting for differential leveling observations is based on either a standard error per
unit length or a standard error per turn.

= Sections as — Select whether you want the “length” numerical value in your leveling
observation data lines to be interpreted as linear length or number of turns.

* Elev Diff — Enter the standard error per unit length or standard error per turn you
want assigned to your elevation difference observations.

When sections are defined as “Length”, the standard error per unit length value is based
on current project units. Therefore:

If units are Feet (US or Int), the standard error per unit length is in Feet/Mile.
If units are Meters, the standard error per unit length is in Meters/KM.
If units are anything else, the standard error per unit length is in Units/Unit.

When sections are defined as “Turns”, the standard error is in Units/Turn.
So, how is the total standard error of a level line between two stations computed?

The total standard error is propagated based on the number of “sections” in the level line,
and as indicated above, these sections are defined as Length or Turns.

Below are two examples, one based on sections entered as Length, the other as Turns.

1. Sections Defined as Length: Project units are in FeetUS, therefore standard error per
unit length is in FeetUS/Mile. So for a level line distance of 25,000 FeetUS between
two stations and an assigned standard error per unit length of 0.015 FeetUS per Mile,
the total elevation difference standard error for the level line will be:

StdErr = 0.015 FeetUS/Mile x SQRT(25,000 FeetUS/5280 FeetUS/Mile)
StdErr = 0.015 FeetUS/Mile x SQRT(4.7348 Miles) = 0.0326 FeetUS

2. Sections Defined as Turns: Project units are in FeetUS, therefore standard error is
based on FeetUS per Turn. So for a level line having 35 turns between two stations
and an assigned standard error of 0.008 FeetUS per Turn, the total elevation
difference standard error for the level line will be:

StdErr = 0.008 FeetUS/Turn x SQRT(35 Turns) = 0.0473 FeetUS
An inline option “.LWEIGHT"” is available if you need to change the default weighting

and the type of weighting (section length-based or turn-based) anywhere in your data.
See “Inline Options” in Chapter 5 for details of its use.
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Listing File Options

These setting allow you to control the contents and appearance of your listing file that
results from an adjustment. With all the contents settings unchecked, a minimum sized
listing will be produced. But even with all contents items selected, some sections will be
listed only if applicable to a particular kind of run.

For the STAR*NET-LEV edition, only the fields relevant to level networks are active as
shown above. For all other editions, Standard, PLUS and PRO, all fields are active.

Option Group: Unadjusted Contents

= Network Observations — When selected, all unadjusted network observation data will
be listed in the output listing file. This is an organized review of all your input data,
sorted by data type. Although this section may be turned off to shorten the listing file,
it is a highly recommended part of any output adjustment report.

= Copy of Input Data File(s) — When selected, an exact copy of your input data file or
files will be copied to your output listing file. Including this section in your listing
greatly increases its length and therefore for normal runs, you will probably not want
to include it. However, in certain cases, it can be very useful for creating a complete
history of an adjustment project including a listing of all original field observation
input data along with the final results.
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Option Group: Adjusted Contents

* Observations and Residuals — When selected, adjusted observations, residuals, the
standard errors and standardized residuals will be shown in the listing file. This is a
tabulation of all adjusted observations, organized by the type of observation.
Although this section may be turned off to shorten the output listing file, it is an
important part of any final report and normally should be included because it clearly
shows how much each observation was changed in the adjustment process.

* Coordinates — When this item is selected, final adjusted elevations will be listed in
the output listing file. When the presence of these values in the listing file is not
important, this option can be unchecked to reduce the size of the listing file.

* Standard Deviations — When selected, computed elevation standard deviations and
elevation vertical confidence values are included in the listing when error
propagation is performed.

* Coordinate Changes from Entered Provisionals — When selected, a tabulation of the
differences between hand-entered provisional elevations and the final adjusted
elevations is included in your listing. This is particularly useful in deformation
studies when you are trying to determine the movement of specific stations since the
previous survey was performed. Only those stations that have explicitly hand-entered
provisional elevations are listed in this section - not those stations whose approximate
elevations are computed by the program.

Option Group: Conventional and Leveling Observations Appearance

= Show Extended Linear Precision — By default, the number of decimal places shown
for linear values in the listing is set to show adequate precision for normal leveling
observations. (For example, 4 places for elevations, distances, standard errors and
residuals.) When this option is selected, 2 additional places of precision are shown
for most linear items. This option satisfies a certain group of users who record
leveling observations using very high precision measuring equipment.

®* Sort Coordinates by — You can select to have elevations shown in the output listing
shown in the same order the points were first found in the input data, or sorted by
point name. Requesting that elevations be sorted by name also causes sorting in the
other output files selected in the “Other Files” options dialog.

®* Sort Unadjusted Input Observations by — Likewise, you can select whether to have
the review of unadjusted input shown in the same order as originally found in the
input data, or sorted by their point names. When sorted, data is sorted first by the
instrument name, then followed by the target name.

* Sort Adjusted Observations and Residuals by — Just as with unadjusted observations,
the adjusted observations may be shown in the same order as originally found in the
data, or sorted by point names. In addition, adjusted observations may be sorted by
the size of their residuals which in some cases may be helpful while debugging a
network adjustment.
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Other Files Options

This dialog is used to select additional output files to be created during an adjustment.
For the STAR*NET-LEV edition, only the fields relevant to level networks are active as
shown above. For the other editions, Standard, PLUS and PRO, all fields are active:

= Create Coordinate (PTS) File - When selected, a coordinate file (elevations only for
level network projects) will be created during an adjustment. This is a text file which
will have the name of your project plus a “PTS” extension (i.e. SouthPark.pts). This
file can be viewed from a selection in the Output menu. Points in this file are created
using a format selected from the Format dropdown menu. The “Default” format will
satisfy most needs, but you might prefer to select another format (i.e. “comma
separated”) that some other program can read directly. For help creating your own
format, call or email Starplus Software.

= Default Precisions — The decimal precisions set in these fields for coordinates, and
elevations are used for creating the PTS file described above. For the LEV edition,
only the Elevations default precision setting is currently used for any output.

» Create Station Information Dump File — Currently the LEV Edition does not include
this feature but may in a future release.

Special, GPS and Modeling Options

For the STAR*NET-LEV edition, the remaining three sections in the Project Options
dialog are not active. The Special dialog currently includes settings relating only to
conventional observations. The GPS dialog provides settings that affect GPS vector
weighting, centering errors, transformation solving and other settings that control the
output content. The Modeling dialog sets up Geoid and Deflection modeling parameters.
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4.5 Company Options

When you create a new project, the default settings that appear in the Project Options are
those settings that exist in the “Company Options.” Therefore if you find that most of
your leveling projects are similar, for example most jobs will use the same standard error
for the observations and you normally want the same output settings, then you should set
these options up as Company Options. For the LEV edition, only fields relevant to
differential leveling network adjustments are shown in any of the dialogs.

First, choose Options>Company. The Company Options dialog appears.

: Company Options
i

L

0000

Then, change settings in all of the options dialogs to those settings most commonly used
for your typical leveling jobs, and press OK to save.

Company Options are stored in the file STAR6.DEF located the STAR*NET system
directory, normally the same directory you chose to install the program. Whenever you
create a new project, this file is automatically read to initialize the Project Options
settings for the new project, saving you the time to do it yourself. Then, after that, you
can fine-tune the settings using the Project Options dialogs when required.

The Company Options default settings can be changed as often as you wish. Just

remember that changing default settings in the Company Options only affects initial
defaults assigned to new projects being created. Existing projects are not affected!
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5.1 Overview

This chapter describes the preparation of STAR*NET input data files. It includes
instructions on using the Input Data Files dialog, a general description of the file format,
a detailed explanation of each STAR*NET data type, a description of “inline” data
options and a discussion of weighting observations.

5.2 Creating Input Data Files

Data for a STAR*NET adjustment consists of one or more text files. For small jobs you
will probably have just a single data file (as in the example above). But for large projects,
you may wish to use several. For example, you might prefer to keep separate areas of
your project in separate files. The Input Data dialog shown above allows you to add or
remove files from the project, edit or view the files, and rearrange the order in which they
will be read during an adjustment.

Each file in the list has a check box. When checked, the file will be read when an
adjustment is run; when unchecked, it will not. This ability to easily include or exclude a
particular file can be very helpful when debugging a network adjustment

When a project is first created, an input data file name using the name of your project is
automatically added to the list in this dialog. For example if your new project is named
SouthPark, a file named SouthPark.dat is added to the list. Although a file named in this
way is not required for your project (you can replace it with another if you wish), most
users will find it a convenient name to use.
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Using the Input Data Files Dialog

To open the Input Data files dialog, choose Input>Data Files, or press the Input Data
Files tool button.

The Input Data files dialog, shown on the previous page, is where you maintain the list of
all data files your project will use during an adjustment. The following describes the use
of this dialog and the functions of its buttons:

Add - Press this button to add a data file to the list. A file selection dialog will open
as shown below. Select an existing file or create a new file. When creating a new file,
type its name in the File name field and press Add. The files dialog defaults to a DAT
extension, however you can use the “Files of type” field to show or add other
extensions. Or add a file of any extension by enclosing the file name and extension in
quotes (for example, “SouthPark.obs”).
'U Nmeto a FiIeList
iC3 Examples
|5 Grid3p.Dat Sideshots.Dat.
LevNet.dat Trav2D.Dat
Net2D.Dat Trav3D.Dat
| preanalysis.Dat [ vectorcombined.Dat

Resection.Dat VectorJob.Dat
Sample.Dat

LA

Remove — Press to remove one or more highlighted files from the list. Files are not
deleted from your computer system, just removed from the list.

Up/Down — When two or more files exists in the list, you can move a file name to a
new position. Highlight the file and press Up or Down to change its position. The
order the files appear is the order they are read when you run an adjustment.

View — Press to view a highlighted file.

Edit — Press to edit a highlighted file, or simply double-click the file in the list. Note
that you can quickly edit the currently highlighted file without even opening the data
files dialog! Just right-click the Input Data Files tool button. (The tool tip for that
button shows the “current” file name.)

The “Project Folder” shown at the top of the Input Data files dialog is where the project’s
PRI file is located, and also by default where the project’s data files are located. If you
add a data file to the list from some other folder, its full relative directory path will be
shown in the dialog.
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5.3 An Overview of STAR*NET-LEV Data Files

STAR*NET input data files are relatively free in format. Generally, lines begin with a
one or two character code identifying the type of data, followed by the station names and
actual observations. These data elements do not have fixed positions on a line, but they
must appear in the proper order.

You may insert comment lines anywhere in the file using the “#” symbol. Anything
following the “#” on a line is interpreted as a comment, and is ignored. We highly
recommend that you add notes and comments to your data files documenting survey data,
field conditions, or any unusual situations that may prove valuable later. To many users,
comments added to their data files become part of an historical document.

Input data files are standard text (ASCII) files that can be created with a text editor, either
inside the STAR*NET program or external to the program.

Data files might also be generated as output from some another program, such as a third
party COGO program or a data collector routine. Starplus Software, for example,
supplies several utility programs that convert raw data collector field files to files
formatted for STAR*NET use. And certain large companies and public organizations
have written their own data converter utilities based on the way their surveyors collect
field data and how they wish to use that data in the STAR*NET program.

Data lines may be up to 500 characters long.

Blank lines can be placed anywhere in the file. You can use spaces and tabs to align the
data items if you wish. Comments, beginning with “#” characters, can be freely entered,
both as separate lines, and attached to the ends of data lines.

5.4 Naming Data Files

File dialogs have been designed in STAR*NET to expect, by default, that input data files
will have a DAT extension. This is a descriptive extension which is very easy to
distinguish from all other file types.

However, the use of DAT as an extension is not required. For example, in the
“Professional” edition, a GPS extension is used when adding GPS vector data to the data
file list. Although it is recommended that observations be created in data files using the
DAT extension so that you can use default file types built into the dialogs, any extension
may be used as long as it is not one of the several reserved output file extensions
automatically used by the program when creating output files.

The following reserved extensions and should not be used for data files: PRJ, LST, PTS,
POS, GND, DMP, ERR, SBF and DXF.
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5.5 The General Content of Data Lines

This section provides a general description of data lines used in STAR*NET. Individual
types of data lines are fully discussed in “Description of Data Format and Content,” later
in this chapter. The box below shows the elements of a data line. Items in [brackets] are
optional:

Code Stations Observations [Std Errors]

Data Type Codes

In general, the first one or two characters of a line of data is a code that defines the
content of the line. (For the LEV edition, all data lines relevant to level networks actually
begins with one character). For example, the line below defines a single differential
leveling data line:

L BM123-823 -3.2345 25345

The example line below defines a fixed elevation for a level network station. The station
is defined as “fixed” by the “!” character located in the standard error field.

E BM123 745.250 !

The following table lists all data type codes that may be used to prefix each line of data.
These codes may be entered in upper or lower case. The “#” symbol is a special code,
indicating that a comment follows, and can be used anywhere on a line.

Code Meaning
# Remainder of line is a comment and is ignored
E Elevation value for a station
C Coordinate values for a station
L Differential Level Data

Data Type Codes

Blank lines in data files are ignored by STAR*NET. They may be inserted anywhere to
separate parts of your data to make the information more readable.
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Station Names

The data type codes used in leveling data files are normally followed by one or two
station names. Multiple names are separated by a dash. For example, in a leveling
observation line, the station name string “TOWER-823” defines the FROM and TO
stations of the observation. Or on a data line that contains an elevation value, a single
name is present to define the station.

Stations can have alphanumeric names up to 15 characters long. You may use upper or
lower case letters. Case is significant, so “corner25” and “CORNER25” are recognized as
different station names. Although it requires care, you can actually mix upper and lower
case to create unique station names, or include special characters such as “/”, “+” or a
decimal point in names for special identification purposes.

Below are a few examples of “level” data lines using a variety of station naming schemes
we have seen in user’s data files:

L 231-257 3.265 1567.123
L R3052E-A0144W 3.265 1567.123
L NorthBridge-ChevronTank 3.265 1567.123
L N564.027-T7582.033 3.265 1567.123
L NGSBM/CE31-RedBluff3 3.265 1567.123
L H16+50.80-4th&Dearborn 3.265 1567.123

Note that since the dash character is used as the separator between station names in
station strings, it should not normally be used within a station name itself. However, if
station names in your existing office records include the dash character, and it is
important to continue their use, a special “.SEPARATOR” inline option is available
which allows you to change the default separator character in your data file from the
default dash to some other character, perhaps a comma. See “Using Inline Options” later
in this chapter for details on the use of this inline option.

Avoid using the following characters within station names: comma, equal sign, the
number sign (#), single quote and double quote. They are reserved for other special
purposes. Also avoid using the name “DUMMYnnnn” where “nnnn” is a number. This
name string is reserved by STAR*NET for internal use as dummy stations that define
fixed backsight bearings in the standard, PLUS and PRO editions.
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Standard Errors

A “standard error” is a value used to weight an observation. When you enter a standard
error value on a level observation data line, the standard error always directly follows the
values making up the observation. A standard error may be entered as a numeric value or
as a special symbol. The following table explains the various entries.

Entry Explanation
Numeric Value An actual Standard Error value (i.e. 0.03)
Nothing Entered Defaults to the value defined in the instrument options

The “&” Symbol Defaults to the value defined in the instrument options
The “!I” Symbol The observation is FIXED
The “*” Symbol The observation is FREE

Standard Error Symbols

Examples of entering explicit standard errors are shown in the next main section
“Description of Data Format and Content”, but in practice you will likely do this only in
special cases. The normal procedure is to enter nothing so that the default instrument
settings in the Project Options are assigned.

Point Descriptors

A point descriptor, if entered, is always the last item on a data line. A descriptor may be
assigned to any station. A descriptor is prefixed by a single or double quote character and
can be up to 48 characters in length.

Descriptors can be entered on Coordinate or Elevation data lines, or any kind of
observation data line. For leveling observation data lines, the descriptor is always
assigned to the “TO” station name. Examples:

2 944.234 'Jones & Taylor
2-7 -8.476 2044 .334 'Descriptor for Sta7

Once a descriptor has been assigned to a network station, any subsequent descriptor
entered for the same station will be ignored. Point descriptors are written to the output
coordinate file as well as to the listing file.
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5.6 Description of Data Formats

This section describes each input data type used by the STAR*NET-LEV edition, and
gives examples of complete data input lines. Note that in the format description of each
type, elements enclosed in square brackets, [ ], are optional.

All data lines allow the entry of descriptors, therefore the descriptor is not mentioned in
the boxes below that describe the formats of the individual lines. Descriptors are always
optional, and if entered on a data line, must be the last item on the line. Some of the
examples show descriptors.

The “E” Code: Elevation for a Station

E Station Elevation [Std Error]

This data type allows you to assign an elevation to a station. The elevation may be fixed,
free or partially fixed depending on what is entered for the standard error field.

Example 1:

E 301 982.53

Station “301” is assigned an elevation of 982.53. No standard error values or fixity
symbol is entered, so the elevation will be assumed completely free to be adjusted.

Example 2:

E 302 845.25 ! ‘Benchmark 105

Station “302” is assigned an elevation of 845.25. This elevation will be held completely
fixed in the adjustment. A descriptor is assigned to the point.

Example 3:

E Doug 1256.5 0.015 ‘GPS E007

An elevation for “Doug” is given standard error and therefore it will provide a partial
constrant in the network. The elevation will be considered an observation and will affect
the results. It will be counted in the statistics and will show up in the “Adjusted
Observations and Residuals” section of the output adjustment listing file.
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The “C” Code: Coordinates for a Station

Format for 2D data:

C Station North East

Format for 3D data:

C Station North East Elevation

Horizontal coordinates (northing and easting values) are not required to perform a level
network adjustment. However, STAR*NET can plot a diagram of your level network if
you enter reference horizontal coordinates for every station in your network. A plot helps
organize and debug a project allowing you to actually see what stations are connected.
These coordinates do not have to be real-world values — they can be at any scale, perhaps
measured from a sketch, or simply estimated. They play no part in the adjustment and are
used only for plotting a diagram. Likewise, the horizontal coordinates do not require
standard errors or fixity characters provided as they play no part in the adjustment.

Note that a level network is considered “3D” because of the vertical element. Therefore
by default, STAR*NET expects any entered coordinates to be in a 3D format. If you find
it more convenient to enter coordinates in 2D format (as shown in the tutorial) you must
enter a “.2D” inline option before these coordinate lines so that STAR*NET will interpret
the data correctly. For information about using the “.2D” and “.3D” inline options, see
“Using Inline Options” later in this chapter.

Example 1: (2D Data)

C A101 1050 2150

Horizontal coordinate values are entered for station A101. These values are entered for
the purpose of creating a plot diagram. They are used for nothing else.

Example 2: (3D Data)

C Al101 1050 2150 624.352 ¥ x ‘Found Pipe

Here 3D coordinates are entered for station A101. The elevation value of 624.352 is fixed
by use of the “!” code. This fixed elevation and affects the network adjustment. The
horizontal values entered for the station will be used only for the plot — they do not affect
the adjustment. The “*” free code was used for the horizontal coordinates only as a place
holder, but any fixity code could have been entered because they are ignored anyway in a
level network adjustment.
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LEVELING DATA TYPE

The leveling data type lets you integrate differentially leveled observation information in
with other data in a 3D adjustment. In the PLUS, PRO and LEV editions, leveling data
can also be independently adjusted using the built-in “Lev” adjustment type.

Leveling observations are similar to “elevation difference” observations which are

entered with the “V” line, except that weighting for differential leveling is based on either
a given distance or a number of turns between the stations.

The “L” Code: Differential Level Observation Information

L From-To ElevDiff Distance [Standard Error]

The distance value entry on the “L” line is used along with the default standard error per
unit length value specified in the Instrument settings of the Project Options to compute
the actual standard error for the observation used in the adjustment.

If you select to have leveling weighting based on “Turns” rather than “Distance” in the
Instrument settings of the Project Options, the value for Distance must be entered as the
number of turns between the From and To stations, not the linear distance between.

If an optional standard error value is entered, this value is used as the actual standard
error rather than a standard error computed based on the section Distance or Turns. You
can also enter the special “!” or “*” character in the standard error field to indicate the
observation is to be completely fixed or free.

Example 1: (Assuming Sections are Entered as Lengths)

L 101-105 -7.476 12634

The difference in elevation between stations 101 and 105 is -7.476 and the distance
traversed between the two stations while taking observations is 12,634. The default
standard error per section length will be used to calculate the observation standard error.

Example 2: (Assuming Sections are Entered as Turns)

L BM335-BM336 | 3.522 24

The difference in elevation between BM335 and BM336 is 3.522 and the number of turns
taken is 24. When entering Turns rather that Distances, select Sections as “Turns” in the
Instrument settings of the Project Options. The default standard error per turn will be
used to calculate the observation standard error.
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Example of Differential Leveling Data

Leveling data can be independently adjusted In the LEV, PLUS or PRO editions using
the built-in “Lev” adjustment type available in those programs. All that is required are
one or more fixed elevations for control and the leveling observations.

However, leveling data can also be included with other data in 3D network adjustments
available in the Standard, PLUS and PRO editions. Leveling data can be entered to
supply vertical observations to some or all stations in a network or to add vertical
redundancy to stations already being defined by other types of observations such as
zenith angles or elevation differences. In this case, any station named in leveling data
must also have other data present which will define its horizontal location. Therefore, a
station in a 3D adjustment named only in an “L” line will cause an error and the
adjustment will terminate.

The example below illustrates a small segment of leveling data that may be integrated
with some other data in a 3D adjustment.

# Leveling Data

L 33-79 2.546 1798

L 79-80 -4.443 931 'Bench 81-1987

L 79-81 0.231 855

L 80-132 1.322 2509 0.14 #Example of explicit Std Error
L 92-93 -5.024 752

.LWEIGHT 0.05 #Change Default Weighting

L 12-15 0.244 1245

L 15-16 3.145 955

etc...

Assuming that units for this project is Meters and the standard error per unit length is set
to 0.008 Meters/Km in the Instrument options, the actual standard error used for the
initial elevation difference observations are propagated from this 0.008 value and the
distance between stations.

On the “L” line describing observations between stations “80” and “132” an explicit
standard error value of 0.14 meters is given. This actual standard error value will be used
for the observation rather than a propagated value.

Note that the default weighting entered in the Instrument settings may be changed using
the “.LWEIGHT” inline option as illustrated above. This inline option is described later
in this chapter along with other inline options available.

When viewing a plot diagram of a network containing leveling observations, straight
lines are drawn between stations containing these observations even though in reality,
these lines are likely made up of many turning points which may wander as the actual
survey did, perhaps around a hill or along a road.

See the tutorial Example in Appendix-A for a complete data set illustrating a small stand-
alone differential leveling network project.
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5.7 Inline Options

There is a category of data called “inline” options that you insert directly into an input
data file, and they affect only those data lines that follow them. Some of these inline
options change default settings originally defined in option dialogs already discussed.
Others perform special functions unrelated to other option settings.

These inline options available in the LEV edition are described on the following pages.

Option Settings Page
.2D/.3D None 37
.DATA ON/OFF 37
LWEIGHT Numeric Value [Turns] 37
.SEPARATOR Character 37
.UNITS [Linear] [Angular] [Std Err] 36
.VLEVEL SectionLengthUnits/NONE/OFF 39
Inline Options

Using Inline Options

The inline option is a powerful feature in the STAR*NET program. Using inline options
allow you control many aspects of your data.

For example, if the units setting in your Project Options is set to feet, the program will
output results in feet, and it will also expect input data to be entered in feet. But if part of
your observations are measured in meters, perhaps supplied to you by another surveyor,
you can simply use the “.UNITS” inline to tell the program that those observations are in
meters. The program does the conversion to meters automatically!

Example use of the “.UNITS” inline option to change units of some leveling data:

# Default units are FeetUS as set in the Project Options

L 24-25 3.6654 20445 #Data in FeetUS
.UNITS Meters

L 51-52 0.8850 7754 #Data in Meters
L 52-53 -1.0232 7633

.UNITS FeetUS #Data in FeetUS
L 66-70 5.2776 24629

etc...
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The following are a few rules for constructing inline options:

1. An inline option begins with a period “.” and is directly followed by the option name
in either upper or lower case. (Examples: .UNITS or .units)

2. An option name may be abbreviated to as little as one character, however sufficient
characters must be supplied to differentiate it from other options beginning with the
same letters. Note that there are more inline options in other STAR*NET editions
than in the subset LEV edition, and all the inline option appreviations must be unique
(Examples: .UNITS or .U, .DATA or .DA, .DELTA or .DE)

3. Many inlines contain parameters which turn an option ON or OFF, toggle a setting
one way or another, or change a value. The same rules apply to parameter names as
with option names. They may also be upper or lower case, and be abbreviated to as
little as one character as long as they are unique. (Examples: ON or OF)

Even though you can abbreviate option and parameters names, it is recommended, that
you spell out enough of the identifier names so that you and others reading your data files
can easily recognize the meanings of the options.

Data for a project may consist of one or more data files. Inline options entered in one data
file do not affect subsequent files. As each file is read during an adjustment, all options
that affect data are reset to the project defaults for the next file. For example, if you use
the “.UNITS” inline to change the units of the input data in one file, it will be
automatically reset to the Project Options default value for units for the next file.

Description of Inline Options

The following inline options allow you to override certain Project Options default
settings that affect the interpretation of your entered data.

INLINE OPTION: .UNITS [Linear] [Angular] [StdErr]

By default, input data must be in the units specified in the Project Options. This inline
option, however, allows you designate the units in data lines that follow. You can specify
linear units, angular units, or both. This option, for example, allows you to easily mix
meters and feet in the same data file. Knowing the units, the program will convert data to
the default units set in the Project Options with no work on your part.

.UNITS FeetUS #Changes linear units for following data
.UNITS Meters #Changes linear units for following data
.UNITS #Resets units back to project defaults

The “Linear” keyword may be any item from the dropdown list of the “Linear Units”
field in the Project Options/Adjustment dialog.
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INLINE OPTION: .DATA ON/OFF

This option is used to easily exclude blocks of data from being loaded by the program,
and is very useful for debugging of data. Simply place a “.DATA OFF” inline before and
a “.DATA ON?” inline after any group of lines that you want ignored.

L BM501-445 3.536 20800

.DATA OFF

L 445-450 2.754 15430 #These lines are ignored
L 450-550 -8.248 18200

.DATA ON

L 445-665 5.443 12600 #Data is now read again

INLINE OPTION: SEPARATOR Character

This inline option allows you to change the default “dash” used to separate station name
strings in observation data lines. For example, if you wish to use dashes within your
station names, you must change the separator to some other character. To do this, enter
the “ SEPARATOR?” inline option along with the new separator character, just before the
data to be affected. You can change the character wherever needed, and to whatever
character you wish as long as it will be unique in the string of station names. If you enter
the inline option without a character parameter, as shown by the second example, the
separator character is returned to the original “dash” default.

L A2-Al 3.346 15300 #using default "-" separator
.SEP , #change to a ", "

L A3,A2 2.443 20340 #using comma separator

L A3-1,A2 9.223 19220 #using dash in a name

.SEP #back to default "-" separator
L A4-A3 -2.554 22300

INLINE OPTION: .2D or .3D

The LEV edition, because of the vertical element, expects data in 3D format. However, in
a level network data file, you may want to enter 2D horizontal coordinates so that a plot
diagram can be created. You can use the “.2D” inline to temporarily change the data
mode to 2D and allow 2D coordinates to be entered. For example:

.2D #Change to 2D data format mode
c BM501 5000 5000 #Enter some 2D coordinates

c BM538 8300 4350

.3D #Change back to 3D data mode

L BM501-445 3.536 20800 #Enter regular 3D data

etc ...
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INLINE OPTION: .LWEIGHT Value [Turns]

This inline option allows you to change the leveling data “Elev Diff” standard error per
section value specified in the Instrument Options to a new value. Enter the inline option
preceding the differential leveling data to be affected and it will remain in affect until
again changed or until the end of the file. At the end of a data file, the the weighting
reverts back to that specified in the project options.

When the inline option is entered with a value only (i.e. without the “Turns” key word),
the program considers the section type based on “Length.” When the “Turns” key word is
included, the program considers the section type based on “Turns.”

The first example sets the value to 0.038 with the section type as “Length.”

The second example sets the value to 0.012 with the section type as “Turns.”

.LWEIGHT 0.038 #Sets 0.038 value and “Length” section type
L BM75-125 15.920 31200
L 129-130 22.130 37400
L 130-125 3.833 28100

.LWEIGHT 0.012 Turns #Sets 0.012 value and “Turns” section type

L 130-126 24.065 46

L 128-126 34.422 38

L 126-127 -15.485 42

.LWEIGHT #Reset to project defaults
L 127-128 9.234 24660

etc...

Units of the entered data are the same units set for the project in the adjustment options,
or the current units if redefined using the “.UNITS” inline option.

If the current units are FeetUS, the new Elev Difference standard error per section length
set for the first example above would be 0.038 Feet/Mile. And the total standard error
propagated for the 31200 foot survey line would be:

Total Std Error = 0.038 FeetUS/Mile x SQRT(31200/5280) = 0.0924 FeetUS.
Likewise the new Elev Difference standard error per section length set for the second
example above would be 0.012 Feet/Turn. And the total standard error propagated for the
survey line having 46 turns would be:

Total Std Error = 0.012 FeetUS/Turn x SQRT(46) = 0.0814 FeetUS

When the inline is entered without parameters as illustrated by the third example, the
weighting scheme reverts to the original default set in the Project Options.
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INLINE OPTION: .VLEVEL SectionLengthUnits/NONE/OFF

This inline allows data from the discontinued DOS-based STAR*LEV program to be
used unchanged in STAR*NET by internally converting the original “V” line leveling
data to information compatible with new the “L” line data format.

The old STAR*LEV program allowed section values to be entered in a variety of units:
Feet (handled as US feet), Miles, Meters, Kilometers, Turns or None. STAR*NET,
however, expects a section value to be either a Length (in the same units as the the
current project units, usually Feet or Kilometers), or as number of Turns.

Enter the “.VLEVEL” option preceding your old STAR*LEV data. Add a keyword to
describe the old data: FEET, MILES, METERS, KILOMETERS, TURNS or NONE. The
examples below illustrate the most common of ways one would use this inline.

The first example inline option tells STAR*NET that the sections are entered as Miles.
Assuming the current project units are in FeetUS, the program will internally convert the
section lengths from Miles to FeetUS.

The second example inline option says to interpret the section value as number of turns.

The third example illustrates the “None” option. In the old STAR*LEV program, the
“None” section length option meant that the section value was not to be used for
weighting and that a given total standard error was to be used for each section. So in this
example, if the project units are FeetUS and the weighting of the old STAR*LEV data
was set to 0.05 feet total per survey line, the following inline would cause a constant 0.05
feet standard error for all following observations regardless of the section values entered.
The entered section length values are ignored.

The last example line turns the “.VLEVEL” option off indicating that any subsequent
data will not need conversion from the old STAR*LEYV data format.

.VLEVEL MILES #Indicates sections are in Miles

vV 101-102 2.5443 2.32 #2.32 Miles will be converted to Feet
.VLEVEL TURNS #Indicates sections are in Turns

vV 101-102 2.5443 8 #The number of Turns is 8

.VLEVEL NONE=0.05 #Indicates to assign 0.05 and simply

vV 101-102 2.5443 123 #ignore section values, 123 in this case
.VLEVEL OFF #Turns the option off

Note that if your old STAR*LEV section data is already in Feet, Meters or Turns, the
data is already compatible with STAR*NET except the “V”codes should be “L” codes.
You can use the “.VLEVEL” inline to define the old data to STAR*NET, but in such a
case, you may find it easier to simply edit your old STAR*LEV data files and change the
data line codes from “V” to “L” and just be done with it!

39




Chapter 5 Preparing Input Data

40



Chapter 6 RUNNING ADJUSTMENTS

6.1 Overview

2 STAR*NET-LEY - LevNet

STAR*NET allows you to specify the type of processing to perform on your input data.
In the LEV edition, you can request a full adjustment of your level network or simply a
check of the data only.

6.2 Adjust Network

To perform an adjustment of your network, choose Run>Adjust Network, or press the
Run Adjustment tool button.

When running the adjustment, STAR*NET reads one or more data files you have
specified in the Data Files dialog. These file are read in the order they appear in the
dialog. As data lines are read and the adjustment proceeds, the status line at the bottom of
the STAR*NET window shows the progress.

In addition, a Processing Summary window appears on your screen to summarize the
progress and results of the adjustment. When an adjustment finishes, a short statistical
summary is displayed in this window indicating how each observation data type fit into
the adjustment. The total error factor for the adjustment is shown and an indication of
whether or not the Chi Square Test passed. A more detailed statistical summary is
included in the output listing. Refer to Chapter 8, “Analysis of Adjustment Output” for
more information on adjustment statistics and results.

If errors or warnings were generated during processing, this is indicated at the end of the
progress information shown in the Processing Summary window. These etrrors or
warnings should always be reviewed as they may indicate errors in your data you must
correct, or warnings that may require your attention. These messages can be reviewed by
selecting Output>Errors or by clicking the Error File tool button. After checking these
messages, you may have to edit your data and rerun the adjustment.

Whenever an adjustment is running, the Run Adjustment tool button changes to a cancel
button, and you can click this button to terminate the processing.
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The STAR*NET adjustment produces a number of files. For example, the listing file
contains the complete results of the adjustment run. The points file contains the
coordinates of your adjusted points. The error file lists any errors or warnings generated
during the run. These files, other output files and a network plot can be viewed from
selections in the Output menu.

6.3 Data Check Only

Before you run an adjustment the first time, you may wish to simply check the input data
rather than run the adjustment. Choose Run>Data Check Only to run this routine. This
is not an adjustment! When you run Data Check Only, a modified version of the listing
file is generated, and you can plot the unadjusted network.

The Data Check Only feature performs two functions:

1. First, all input data is read into memory. If you have any syntax errors in your data
files, STAR*NET will issue error or warning messages in the error file which you
can review and take any action required. Your input data observations will be
summarized in the listing file.

2. Secondly, all level observations found in the input data are checked for consistency
with the approximate coordinates.

Whenever STAR*NET-LEV reads in data, approximate coordinates (elevations) are
computed for all points using the observations found in your data. The program then
calculates the difference between each “entered” observation and its respective
“inversed” observation calculated from the approximate coordinates. Your listing file will
contain a section entitled “Differences from Observations” for each data type. Some
observations will show no differences since they may have been used to actually
calculate the approximate coordinates. But other observations not used to calculate
coordinates may show some differences. When observations in a network are consistent
with each other, differences shown in the listing should be quite small. The appearance of
large difference values likely indicates bad observations, or errors in preparing data,

This ability to check consistency of input observations to approximate coordinates is
particularly useful for finding “badly” fitting observations being added to a known
“good” network. Simply supply the coordinates from your previous good adjustment of
the network as approximate coordinates in your new data. (When approximate
coordinates are supplied, they won’t be computed from the observations.) Run the Data
Check Only routine and then check the listing for any of the new observations not fitting
the “good” approximate coordinates.

As indicated above, the Data Check Only routine only reads in data and does a simple

check of consistency between observations and approximate (calculated or entered)
coordinates.
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Chapter 7 VIEWING AND PRINTING OUTPUT

7.1 Overview

-z STAR®NET-LEY - LevNet

The output menu allows you to view output files resulting from running an adjustment, or
from running any of the other types of processing from the Run menu described in the
last chapter. The “Listing” and “Plot” are the two types of output that you usually will
view immediately after an adjustment. There are tool buttons provided for these two
outputs so you can quickly and easily select them.

NOTE! This chapter illustrates how to view and print listing sections and plots. All
illustrations are shown with conventional survey network examples created by using the
standard STAR*NET edition. These viewing facilities work the same for the LEV edition
although some option settings in the Plotting facilities will be inactive as they do not
relate to level network data.

7.2 Output Files

The following output can be viewed and printed directly from this menu. Some of these
files are created only if options are set in the Project Options requesting them.

= Listing File - This file is the most important of all output files. It contains detailed
results from the current run and is the main output document from an adjustment. The
information in this file includes summary of input, adjustment statistical summary
and adjusted observations and residuals output. It is described in detail in the next
chapter, “Analysis of Adjustment Output.”

»  Error File — Only created when the run produces errors or warnings.
= Coordinates File — Adjusted elevations, optional.
»  Plot — The graphical network screen plot for a leveling network will be created by the

program from a special binary file created during the run. For a level network plot to
be created, horizontal reference coordinates must be supplied for all stations.
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7.3 Viewing and Printing the Listing

To view the Listing, choose Output>Listing, or press the Listing tool button.

Copyright 15688-2002 Starplus Software, Inc.
Licensed for Use by ABCD Land Surveyors
Run Date: Sun Mar 17 2002 15:48:29

¥ of Files Usad and Option Settings
(& Summary of Unadiusted Input Observations
i Adjustment Statistical Summery
[ Adusted Station Information
- Adpusted Observations and Residuals

i Adpusted Bearings and Horizontal Distances
& Traverse Closures of Unadjusted Observations
- Enor Propagation

End of File

Summery of Files Used and Option Secttings

Project Folder and Data Files
Project Name GRID3D
Project Folder C:\STARPLUS\STARNET\EXANPLES
Data File List Grid3D.dac

Project Option Settings

STAR*NET Run Mode ¢ Adjust with Error Propagation

Type of Adjustment 3 3D

Project Units : FeetU3:; DNS

Coordinate System ¢ Lambert NAD83: CA Zone 3 0403

Geoid Height ¢ -32.0000 {Default, Meters)
Longitude Sign Convention ¢ Positive West

Input/Output Coordinate Order : North-East

Angle Data Station Order ¢ At-From-To 1
Distance/Vertical Data Type : Slope/Zenith :
Convergence Limit; Max Iterations : 0.010000; 10

Default Coefficient of Refraction ¢ 0.070000

Create Coordinate File : Yes

Create Geodetic Position File : Yes

Create Ground Scale Coordinate File : Yas

1

The listing file maintains an internal “table of contents” which knows the location of all
major sections. You can press the tool buttons on the listing window’s frame to jump
forward or backward in the file one heading at a time, a whole section at a time, or to the
end or top of the file. And, of course, you can scroll using the scroll bars.

You can also pop up a “Listing Index Tree” window by pressing the Listing Index Tree
button on the listing window tool bar, or by right-clicking anywhere on the listing. This
window displays a table of contents for the entire listing file. Use this Index Tree to
quickly jump to specific sections of the listing. Click any listing section to jump to that
location. Open and close listing sections using the [+] and [-] tree items just as you would
in Windows Explorer.

Both the Listing and Listing Index Tree windows have a memory, and each window will
appear the same size and at the same location the next time STAR*NET is run. Resize
these windows and position them in any way you prefer. For example, in the STAR*NET
window shown above, listing window has been sized large enough to show the whole
width of the listing, and the index window small and off to one side. If your screen size
and resolution is sufficient to show both windows simultaneously, you can check the
“Keep on Top” box on the Index window, as shown above, so that when the listing
window is active, the Index will always pop up — a convenience!
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To search for text in your listing file, either select “Find” from the Edit dropdown
dialog on the main window, or simply press Control-F.

You can Preview or Print your listing anytime the Listing window is active. Before doing
either, you should use the “Text Page Setup” dialog from the File menu to set printing
options such as what printer to use, portrait or landscape printing orientation, desired
margin sizes, and page numbering. Once these options are set, they will remain set until
you again want to change them.

If you wish, preview your listing by choosing File>Print Preview, or by pressing the
Print Preview tool button on the main window:

+x STAR*NET - Grid3D

< Amastet.
Comats Grewst Sesle Coantimats file : Ymx
Comatn Wanp fiim t vem

Imscwmmt Sawmisvd Cecor Smttimyr

To print your listing file, choose File>Print, or press the Print tool button on the main
window, or press the Print button from the Print Preview window.

When you print, a print dialog opens and allows you to choose to print “all” of the listing,
or a selected page range in the listing. Or if you have highlighted a few lines in the listing
window, for example some adjusted angle observations and residuals, you can choose to
print this “Selection” only.

Important! Note that if the listing file text is edited external to STAR*NET, the internal
table of contents will be lost, and the “Listing Index Tree” and the navigation tool buttons
will no longer work. If you need to edit you listing for one reason or another, first make a
copy of it (your “ProjectName.lst” file) and then edit the copy!
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7.4 Viewing the Error File

During an adjustment, errors or warnings messages may be issued by the program. If the
processing summary indicates that there were errors or warnings, you should always view
them to see what course of action should be taken.

To view the Error file, choose Output>Errors, or press the Errors tool button. Note that
the Errors tool button (the red exclamation mark) only becomes active if an error file has
been created. And like other output files, when the error file window is active, the file can
be printed by choosing File>Print, or by pressing the Print tool button.

7.5 Viewing Adjusted Points

For the LEV edition, the Coordinates file which contains the adjusted elevations may be
created. View this file by selecting them from the Output menu.

#x STAR*NET - Grid3D

2186970. 6417594.
2186836. 6415494,
2187358. 6418680,
2189059, 6418856.
21689121. 6417390.
2191139. 6417066.
2190461. 6415845,

And like any of the output files, when selected file window is active, the file can be
printed by choosing File>Print, or by pressing the Print tool button.
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7.6 Viewing and Printing the Network Plot

To view the Plot, choose Output>Plot, or press the Plot tool button.

[ 4 STAR*NET - Grid3D

4 Network Plot

Four tool button groupings allow you to perform several plotting functions:

» The first group are zoom buttons. Use them to zoom in and out, zoom to extents, and
return to the previous zoom.

=  The next group includes “Center-on-Click” and “Pan” features. These buttons set
modes which remain in effect until the button is again pressed, or until you right-
click on the plot. Use the “center-on-click” mode to click on a network feature and
cause that point to center in the plot window. When the “pan” mode is active, a small
hand appears as the mouse cursor. Drag this hand to pan the plot image.

= The next two buttons bring up “Find” and “Inverse” dialogs. Type a point name in
the Find dialog or select it from the list. Press “Find” and the plot will center on that
point. In the Inverse dialog, type point names in the From/To fields, or select them
from the list, or click the points in the plot (which fills-in the names) and press
“Inverse.” An information box appears showing the inversed distance, azimuth and
elevation difference. See the example above. Note that the Find and Inverse dialogs
both may be moved off to the side of the plot, and they will stay there, out of the
way, while the plot window is open.

= The last button brings up a “Plot Options” dialog which is explained next.
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Press the “Plot Options™ tool button to view and
edit several plot settings.

In this tabbed dialog, several plotting options can
be set which affect the appearance of the plotted
image. Plotting options are saved in the “project”
options so that when a project is opened another
time, the plot will have the same appearance.
Each project remembers its own individual plot
options.

Plot Uphions

The “Plot” tab shown below allows you to
individually turn on and off various network and
sideshot objects such as station names, markers,
descriptors, ellipses and relative ellipses.

The “Sizing” tab allows you to resize text, markers and ellipses. The initial ellipse
exaggeration for a plot is automatically set to a show the largest ellipse at some
percentage of the plot extents. You can change the exaggeration, or at any time press
“Reset” to change back to the automatic value.

The “Special” tab shown below includes options useful when viewing certain types of
plots. For example, the “Show Only Fixed Names and Station Markers” option shows
only your “fixed” control points in a network plot.

The “Save” tab allows you to save the current settings (which plotting objects to show,
sizes of names and markers, etc.) as typical so that they will be used as starting defaults
for any new job created. Note that ellipse exaggeration is not saved as typical; ellipse
sizes are handled separately for every project.

Press the “Apply” button any time to see the effects of any setting changes.
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Pop up a “Quick Change” menu by right-clicking anywhere on
the plot. Click any item on the menu to perform a single function.
For example, to quickly turn network “Names” off, first right-
click to get the quick change menu, and then click the “Show
Names” item to uncheck or disable names.

You can also access all the “Tool Button” functions from this
popup menu as well as bring up the full the Plot Options dialog
discussed on the previous page.

Use this quick change menu for an easy way to access the Plot
Page Setup dialog for setting up the printer before previewing or
printing a network plot. Printing of your plot is described later in
this section.

Some Keyboard “Hot” keys available also toggle some plotting items on and off:

= Toggle point names, markers and descriptors with N, M, and J.
» Toggle sideshots, sideshot names, markers and descriptors with: S, X, C and D.
= Toggle ellipses and relative ellipses (when computed) with E and R.

Other basic mouse operations in the plot window include the following:

» Drag a box around any area of the plot to quickly zoom in. Drag a zoom-box by
holding down the left mouse button and dragging a rectangular enclosure.

» Double-click any point or line to get its adjusted
information including error ellipse values if
error propagation was performed. The
information box can be moved off to one side,
out of the way. Double-click another point or
line and the information box will refresh.

The example shown is adjusted information for
station 5 including coordinates, elevation and
error propagated ellipse values.

= As you move the mouse around the plot
window, North and East coordinates displayed
in the status line are continuously updated with
the project coordinates at the mouse pointer.
The width of the window is shown in project
units so that any time you zoom in, or resize the
window, you always have a good sense of the plot scale.

Just like with the Listing Window, the Plot Window also has a memory. Once you size
and locate the window, the next time the program is run and a plot is displayed, the plot
window automatically appears the same size and in the same location.
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You can Preview or Print your plot anytime the Plot window is active. Before doing
either for the first time, you should use the “Plot Page Setup” dialog from the File menu
to set printing options such as what printer device to use and whether to print in portrait
or landscape orientation. Note that you can to print your plot on a different device than
you print your text files. Once these options are set, they will remain set until you again
want to change them. You can also quickly review the plot page setup from the “Quick
Change” popup menu described in the previous section.

To preview your plot, choose File>Print Preview, or press the Print Preview tool button
on the main window:

F STAR'NET

To print your Network Plot, choose File>Print, or press the Print tool button on the main
window, or press the Print button from the Print Preview window.

A few words should be said about composing your plot on the sheet. Plotting in this
program is simply printing a diagram. There is no precise control of plotting scale or
sizing of point names or markers. However, the general appearance of the diagram can be
easily controlled by resizing the plot window to the approximate shape and orientation of
the target sheet. Place (by zooming or panning) the network image within the plot
window exactly how you want it to appear on your final sheet. Resize the point names
and markers larger or smaller, resize the ellipses (or turn them off), etc. What you see will
be what you get. Preview the plot, and then if necessary, make any changes before
printing. You will need to experiment with this.
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Chapter 8 ANALYSIS OF ADJUSTMENT OUTPUT

8.1 Overview

Your objectives in performing a Least Squares Survey Adjustment are to eliminate
blunders from your data, compute the best fit adjustment for all survey observations
simultaneously, and to evaluate the accuracies of the adjusted survey points.

This chapter is designed to help you interpret a STAR*NET adjustment output listing.
You can use the output listing to :

= Review all of your input field observations

» Locate and correct gross blunders in your input data

=  Analyze the strength of your survey observations

» Determine the positional accuracies of computed elevations

STAR*NET stores the output from an adjustment in a file called “PROJECT.LST”,
where “PROJECT” is the name of your current project. You can view this file within the
program by choosing Output>Listing, or by pressing the Listing tool button.

You control the sections that STAR*NET places in the output listing file by settings in
the Project Options/Listing dialog. During the data checking phase, you may want to
produce a minimally detailed listing, and then later, turn on additional sections of the
report you now want included. Depending on the type of adjustment, some of the output
listing sections shown below will not be available.

8.2 Sections of the Output Listing

Summary of Files Used and Options Settings

Listing of Input Data Files (optional)

Summary of Unadjusted Input Observations (optional)
Adjustment Statistical Summary

Coordinate Changes from Entered Provisionals (optional)
Adjusted Elevations and Error Propagation (optional)
Adjusted Observations and Residuals (optional)

The remainder of this chapter discusses each section of the output listing file, providing
hints on adjustment analysis. It concludes with a section of procedures that you can
follow to locate and correct errors in your survey data.
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8.3 Summary of Files Used and Options Settings

The first few lines of the listing file identify the version of STAR*NET that you are
using, and your licensing information. The exact time and date of the run is shown, so
that you can keep track of multiple runs of the same project. The project name, project
folder and names of all input data files used in the adjustment are listed next. Last comes
a summary of the option settings that were in effect at run time.

8.4 Listing of Input Data Files (Optional)

This section of the listing file is a direct line by line copy of your input data files. This
can be useful for historical documentation purposes, because it contains all of your input
data plus any comments you included in your data when it was prepared. This section is
optional, and normally you will include it only for documentation or debugging purposes.

8.5 Summary of Unadjusted Input Observations (Optional)

STAR*NET creates an optional summary of your unadjusted observations. These
observations are listed with their standard errors. Leveling observations fixed in the data
with the “!” code will show up with a standard error value lablel of “Fixed”, and those

freed with the “*” symbol will appear with a label of “Free.”

The following illustrates the format of this section of the listing file:

Summary of Unadjusted Input Observations

Number of Entered Stations (FeetUS) = 4
Fixed Stations Elev Description
TIDAL1 1.3750 NGS Ref 1
BM75 23.7680
etc ...

Number of Differential Level Observations (FeetUS) = 14

From To Elev Diff StdErr Length
TIDAL1 129 12.3450 0.0117 20100
BM75 129 -10.0230 0.0131 25300
BM75 125 15.9200 0.0146 31200
129 130 22.1300 0.0160 37400
130 125 3.8330 0.0138 28100
BM26 126 2.8140 0.0163 39200
etc ...

Summary of Unadjusted Input Observations (Leveling)
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8.6 Adjustment Statistical Summary

The Statistical Summary, although short, especially for a level network adjustment
contains some of the most useful and important information in the entire listing. You
should always review it, especially if you are having problems with your adjustment.

Adjustment Statistical Summary

Number of Stations = 10

Number of Observations = 14

Number of Unknowns = 6

Number of Redundant Obs = 8
Observation Count Sum Squares Error
of StdRes Factor
Level Data 14 6.552 0.905
Total 14 6.552 0.905

The Chi-Square Test at 5.00% Level Passed
Lower/Upper Bounds (0.522/1.480)

Statistical Summary (Leveling)

The first item indicates how many stations are actually included in the network. Any
station included in your data file, but not actually connected to any other station by one
or more observations, is not included in this count.

The next three lines indicate the numbers of observations, unknowns and redundant
observations in the network. The number of redundant observations, often called the
“Degrees of Freedom” of the network, is equal to the number of observations in the
network minus the number of unknowns. This is also sometimes called the redundancy of
a network.

The following discussion relating to the calculation of the individual and total error
factors is general in nature and illustrates how certain values are created for 2D and 3D
networks. The same information, however, applies to simple 1D level networks. This is
the same discussion as is presented in the full STAR*NET reference manual.

The total number of observations in the network define the number of condition
equations to be solved by the adjustment. Basically, each observation such as distance,
angle, or partially fixed coordinate contributes one condition equation. Note that any
coordinate component entered with a standard error value (i.e. not fixed or not free) is
considered an observation just like an angle or distance. The “count” of coordinates in the
statistics listing is the number of individual components (northings, eastings or
elevations) that have standard errors given, not the number of stations. For example, the
count of 3 shown in the sample listing might indicate that a northing, easting and
elevation have each been entered with a standard error. Measurements such an angles and
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distances that are entered as “free” (using the “*” code) are not included in the
observation count. A “free” observation does not contribute in any way to the adjustment,
and therefore will not affect the statistics.

The number of unknowns are counted by adding up the “adjustable” coordinate
components. Each 2D station will add two unknowns (or less depending on whether any
components are fixed), and in a like manner, each 3D station will add three unknowns.
Any northing, easting or elevation component that is entered as fixed (using the “!” code)
is not counted as an unknown. In addition, every direction set present in the data will add
another unknown. (Each set of directions includes a single unknown orientation that will
be solved during the adjustment.) The network is considered “uniquely determined” if the
observations equals the unknowns, and “over-determined” if the observations exceeds the
unknowns, making the number of redundant observations or degrees of freedom greater
than zero. The network cannot be solved if the degrees of freedom are less than zero.

For example, a simple 2D quadrilateral with two fixed stations has four unknowns (two
free stations times two coordinates per station). If five distances and eight horizontal
angles are measured, the number of redundant observations is equal to nine (13 - 4). In
general, the more redundant observations the better. However, the added observations
should be spread evenly throughout the network. If you had measured only the four
exterior distances of a quad, you would not add as much strength by measuring those
distance twice, compared to measuring the cross-quad distances, even though you might
add the same number of degrees of freedom to the solution.

Next, the Statistical Summary contains a line for each data type existing in the network.
Each line lists a count of the number of observations of that type, the sum of the squares
of their standardized residuals, and an error factor. A residual is the amount the
adjustment changed your input observation. In other words, the residual is simply the
difference between the value you observed in the field, and the value that fits best into the
final adjusted network. The standardized residual is the actual residual divided by its
standard error value. This value is listed in the “StdRes” column for every observation in
the “Adjusted Observations and Residuals” section of your output listing file.

To compute each total in the “Sum Squares of StdRes” column, each Standardized
Residual is squared and summed. (This total is also often called the sum of the squares of
the weighted residuals.) A large total for this summation is not that meaningful in itself
because the size of the total is a function of the number of observations of that data type.
The totals displayed in the Error Factor column, however, are adjusted by the number of
observations, and are a good indication of how well each data type fits into the
adjustment. Among different data types, these Error Factors should be roughly equal, and
should all approximately be within a range of 0.5 to 1.5. If for example, the Error Factor
for angles is equal to 15.7 and that for distances is equal to 2.3, then there is almost
certainly a problem with the angles in the adjustment.

An Error Factor may be large for several reasons. There may be one or more large errors
in the input data, there may be a systematic error (i.e. EDM calibration problem), or you
may have assigned standard errors that are unrealistically small. Note also that a large
angle error can easily inflate the distance Error Factor, due to the interconnection of
common stations. The final section in this chapter provides a number of techniques for
locating potential sources of problems in the adjustment.
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The “Total Error Factor” is an important item in the Statistical Summary. It is calculated
as the square root of the Total Sum of the Squares of the Standardized Residuals divided
by the Number of Redundancies:

SQRT (Total Sum Squares of StdRes / Number of Redundancies)

The Total Error Factor is also commonly referred to as the Reference Factor, or the
Standard Error of Unit Weight. This value is used for statistical testing of the adjustment,
as explained in the next section.

Finally, at the end of the Statistical Summary, there is an indication whether on not the
adjustment passed the Chi Square test. This test is discussed next.

8.7 Chi Square Test

After the iterations of an adjustment solution cease, STAR*NET tests the adjustment to
determine whether the resulting residuals are likely due to random errors by performing a
two-tailed Chi Square statistical test at the significance level specified in the Project
Options General dialog. A 5% significance level is the is the generally accepted level to
accept or reject a statistical hypothesis.

In statistics, a ¢* value (a Chi Square statistic) derived from a process having random
errors will, on infinite repetition, produce a frequency distribution that is a function of the
number of degrees of freedom. For example, assuming a 5% significance level, the two-
tailed Chi Square test checks whether a particular ’ value falls within the middle 95%
region of all possible x* values in the distribution. If it does, the * value is accepted (i.e.
the Chi Square test passed) as due to random error influences. If not, the x> value fell
either in the lower 2.5% or upper 2.5% of the distribution (the Chi Square test did not
pass), and it is assumed due to non-random error causes — systematic errors, blunders,
incorrect standard errors, etc.

In a least squares adjustment of survey observations, the sum of the squares of the
standardized residuals is a ? statistic. The frequency distribution for this statistic could
be determined by repeating many times without systematic error or blunder the same
exact survey and adjustment, each time producing a new and likely different sum of the
squares of standardized residuals. The collection of sums can be represented as a
frequency distribution which can then be used to test acceptance of the residuals in the
first survey. Fortunately, this huge effort isn’t necessary because we know that all ¥
statistics, including the sum of the squares of the standardized residuals, conform to the
mathematical formula for the Chi Square distribution, which is dependent only on the
number of degrees of freedom.

In a STAR*NET survey adjustment, the number of degrees of freedom is the difference
between the number of observations and the number of unknowns, i.e. the redundancy in
the survey. Observations consist of the usual field measurements that are not declared
free, together with any coordinate values entered with partial fixity. The count of
unknowns includes all connected coordinates that are not fixed, one internal orientation
for each direction set, and the computed transformations applied to GPS vectors.
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An alternate view of the Chi Square test is that it compares the Total Error Factor
obtained in the adjustment against its expected value of 1.0. The total error factor is a
function of the sum of the squares of the standardized residuals and the number of
degrees of freedom in the adjustment. When the sum of the squares of the standardized
residuals is exactly in the middle of its random distribution and as the number of degrees
of freedom increases, the total error factor approaches exactly 1.0. The assumption that
the adjustment residuals are due solely to random influences is rejected when the total
error factor is smaller than or larger than 1.0 by some magnitude dependent on the
number of degrees of freedom and the confidence level desired.

The Chi Square test can fail by exceeding the upper bound or the lower bound. When the
test fails, a waning is printed at the end of the Statistical Summary indicating which
bound was exceeded. This example failed by exceeding the upper bound.

Warning: The Chi-Square Test at 5.00% Level Exceeded Upper Bound
Lower/Upper Bounds (0.522/1.480)

When the Chi Square test fails by exceeding the upper bound, this indicates that you may
have excessive residuals and/or you may have misstated the observation standard errors
by setting them too small. You should always determine the reason a Chi Square test fails
by exceeding the upper boundary and make necessary corrections.

When the Chi Square test fails by exceeding (being lower than) the lower bound, there is
usually no serious problem but you should still determine the reason why. This usually
indicates that the residuals are smaller than what is expected relative to the applied
standard errors. If you feel your standard errors are proper, no changes are necessary.

In summary, the Chi Square test, often called the “goodness-of-fit test,” statistically tests
whether your residuals are due to normal random errors. If the adjustment fails the test,
first check the standard error values (weighting) you have assigned to your observations.
And if the Chi Square test failed by exceeding the upper bound, then check for mistakes
which can include blunders in your actual observations, fieldbook recording errors, or
data preparation errors such as incorrectly entered measurements or misnamed stations in
the input data file.

56




Chapter 8 Analysis of Adjustment Output

8.8 Coordinate Changes from Entered Provisionals (Optional)

STAR*NET optionally lists differences between hand-entered provisional coordinates
and final adjusted coordinates. This option is particularly useful in deformation studies
where the purpose is to determine how much certain stations moved since the previous
survey. To do this, enter the specific adjusted coordinates from your previous survey as
provisional (approximate) coordinates for a new survey, and request this optional listing
section in the Listing options dialog. Only changes from these hand-entered provisional
coordinates will be shown in this special output listing section.

This example is from a level network adjustment. Station elevations from a previous
adjustment were entered as free provisional elevations for another adjustment. The listing
section below shows the changes to those elevations since the previous adjustment.

Coordinate Changes from Entered Provisionals (FeetUS)

Station dz
129 0.0299
125 0.0057
130 0.0023
128 0.0277
126 0.0023
127 0.0057
etc ...

Coordinate Changes from Entered Provisionals (Leveling)

When entering provisional coordinates to be used as the basis for computing the changes
as described above, it is important to place these coordinate values at the beginning of
your data so that they will be read “first” during the processing.

Why is this? When STAR*NET reads data and finds more than one set of approximate
coordinates for a particular station, only the “first” coordinate values are remembered.
The remaining are ignored. Therefore, placing your provisional coordinates first in the
data assures you that some other approximate coordinates may be already existing later in
the data will not corrupt your desired results.

You might consider creating your “provisional” coordinates in a separate file, and placing
this file as the first entry in your data file list. Then at some future time when you want to
update the provisional coordinates for a subsequent run, simply replace that file’s
contents with the newer provisional coordinates.
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8.9 Adjusted Elevations and Error Propagation

Output reporting for the Adjusted Elevations and Error Propagation for a level network
adjustment is shown in the same listing section as illustrated by the output below. If error
propagation is not performed, the station standard deviation and percent confidence
values will not be output.

Adjusted Elevations and Error Propagation (FeetUS)

Station Elev StdDev 95% Description
TIDAL1 1.3750 0.000000 0.000000 NGS Ref 1
TIDAL2 2.1650 0.000000 0.000000 NGS Ref 2

BM75 23.7680 0.000000 0.000000

BM26 57.1290 0.000000 0.000000 Brass Cap 1939
129 13.7299 0.007673 0.015040

125 39.6867 0.009283 0.018194 At Hyde

130 35.8643 0.009869 0.019343 Central

128 25.5307 0.010557 0.020692

etc

Adjusted Elevations and Error Progagation (Leveling)

8.10 Adjusted Observations and Residuals

The adjusted leveling observations and residuals report from a level network adjustment
is similar to the reporting for observations in 2D and 3D adjustments.

Adjusted Observations and Residuals

Adjusted Differential Level Observations (FeetUS)

From To Elev Diff Residual StdErr StdRes
TIDAL1 129 12.3549 0.0099 0.0117 0.8
BM75 129 -10.0381 -0.0151 0.0131 1.1
BM75 125 15.9187 -0.0013 0.0146 0.1
129 130 22.1344 0.0044 0.0160 0.3
130 125 3.8224 -0.0106 0.0138 0.8
129 128 11.8008 -0.0092 0.0169 0.5
128 130 10.3336 -0.0024 0.0148 0.2
125 BM26 17.4423 -0.0157 0.0160 1.0
BM26 126 2.8173 0.0033 0.0163 0.2
130 126 24.0821 0.0171 0.0167 1.0
etc

Adjusted Observations and Residuals (Leveling)
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Overview

STAR*NET is a program package that performs least squares adjustments of two and
three dimensional survey networks and level networks. It is menu driven for ease of use,
and allows you to edit your input data, run your adjustment and view the adjustment
results all from within the program. STAR*NET also includes graphics display routines
that allow you to view your network, including the error ellipses from your adjustment.

Although STAR*NET is easy to use, it is also very powerful, and utilizes the latest
rigorous adjustment and analysis techniques. In three dimensional mode, it performs a
simultaneous adjustment of three dimensional data, not simply an adjustment of
horizontal followed by an adjustment of vertical. This makes STAR*NET well suited to
the processing of total station data, and the analysis of data sets for establishing control
for close-range photogrammetry and structural deformation monitoring. However, it is
equally suitable for the adjustment of traditional horizontal traverses.

This tutorial is designed to be used with the STAR*NET-LEV program edition. The
supplied sample project will acquaint you with some of the capabilities of the package.

Example Project: Differential Leveling Network

In the tutorial, we will go through the same sequence of operations that you would
normally follow when creating and adjusting a survey network.

The normal sequence of operations one goes through in adjusting a project is: set project
options, create input data, run an adjustment, review results including viewing both an
adjusted network plot and an output listing report. But in these example, we will be just
reviewing options and data, not setting options and creating new data.

60



Appendix A STAR*NET-LEV Tutorial

Example project provided for this tutorial is located in a subdirectory of your install
directory named “Examples.” Therefore:

= Ifyou installed your STAR*NET program in “C:\Program Files\Starplus\StarNet,”
=  Your example projects are in “C:\Program Files\Starplus\StarNet\Examples.”

Each sample project consists of a “Project” file (a file with a “PRJ” extension) and at
least one “Data” file (a file with a “DAT” extension). An existing project is opened by
selecting its “PRJ” file from the Open Project dialog.

The “Project” file contains all the option settings for a project such as whether it is a 2D
or 3D job, a local or grid job, all instrument standard error settings, and much more
information. The project file also includes a list of all data files that are considered part of
the project. All settings are preset for these sample projects, so you can simply review
them and not be concerned about setting any yourself.

All “Data” files used in STAR*NET are simple text files that may be prepared within the
program or external to the program using any text editor. All of the input data files for the
sample projects are provided, with full comments, to help you get an idea of how to apply
STAR*NET to your adjustment problems. It is not required that you edit any of these
sample data files when running the sample projects.

In all following examples in this tour, the instructions simply ask you to open a named
project. Choose File>Open Project, or press the Open tool button, and the following
dialog will appear allowing you to select one of the existing sample projects.

Examples

.@ TravzD.Prj
TravaD.pri
VectorCombined.Prj
Preanalysis.Prj VectorJob.Prj
Resection.Prj
Sideshots.Prj

If for some reason the sample projects as shown above do not appear, browse to the
folder you installed the STAR*NET program, open the sub-folder named “Examples”
and you will find them there.

Note! For the sake of simplicity in this tutorial, the dialogs that show the path of the
example projects indicate that the “Starplus” directory is located right at the root.
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Differential Leveling Network

This example demonstrates running a stand-alone differential level network adjustment.
A stand-alone “Lev” adjustment type is available in the PLUS, PRO and LEV editions.
Level data may also be included in any 3D adjustment type in the STAR*NET suite.

# Simple Level Network with 4 Fixed Benchmarks
# Fixed Elevations

E TIDALL 1.375 ! 'NGS Ref 1

E TIDAL2 2.165 ! 'NGS Ref 2

E BM75 23.768 |

E BM26 57.129 ! 'Brass Cap 1939
# Leveling Observation Data

L TIDAL1-129 12.345 20100

L BM75-129 -10.023 25300

L BM75-125 15.920 31200

L 129-130 22.130 37400 'Central
L 130-125 3.833 28100 'At Hyde
L 129-128 11.810 41700

L 128-130 10.336 32100

L 125-BM26 17.458 37500

L BM26-126 2.814 39200

L 130-126 24.065 40900

L 128-126 34.422 52200

L 126-127 -15.485 48100

L 128-127 18.95 45300

L TIDAL2-127 42,321 17700

# To produce an optional plot diagram, BM75

# supply 2D coordinates at any scale.

[N
o

TIDAL1 11
TIDAL2 0
BM26 5
BM75 12
125 8.
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1
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Open the “LevNet.prj” example project. Note that this stand-alone “Level” project
will run if you are using the PLUS, PRO or LEV editions.

Open the Project Options for this job and review the “Adjustment” options page.

Here the “Lev” adjustment type has been selected. The only setting required on this
dialog is the default linear units of input and output.

Review the “General” options page.

Again, only a few options settings are needed for a level network adjustment. There
are no iterations required for this kind of adjustment as the solution is linear. Why is
there a “Coordinate Order” option for a level network? As illustrated by the data,
Northing and Easting coordinates may be optionally entered for each station if you
want a schematic plot generated for your level network. More on this later.

Review the “Instrument” options page.

Here the default standard error for the leveling observations is set. Weighting for
differential leveling can be defined by section length or by the turns. For this
example network, the elevation difference standard error for each observation will be
propagated by the program using 0.006 FeetUS per Mile section.
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5. Also review the “Listing File” and “Other Files” options pages in the Project
Options if you wish. A few options can be set relating to output for a level network.

Examine the data file if you wish. You will note this simple network includes four
fixed elevations and 14 leveling section observation “L” lines. These two types of
data lines are the only types required to perform an adjustment. Note however that
2D coordinates have also been provided for all the stations in the network. These are
optional and need be entered only of you wish the program to create a schematic plot
of the level network. Since these coordinates will only be used to create this plot, the
scale of the coordinates makes no difference. Coordinates entered in this example
were simply scaled off a sketch of the network drawn on grid paper.

Run the network adjustment.

Look at the network graphically. As mentioned above, this is only a schematic plot
based on the relative 2D coordinates entered. Although straight lines are shown
between connections, in actual leveling networks these connections may actually
follow along roads, wander around hills, etc.

B 5 Network Plot

f Network Connection

While viewing the diagram, double-click any point to get a pop-up information box
showing its adjusted elevation and confidence region values. Double-click on other
points and the information will refresh. Double-click on any line to show its adjusted
elevation difference and relative confidence values. The example pop-up box shows
information generated by double-clicking connection 129-128 on the plot diagram.
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9. View the output listing and browse through the various sections as you did in
previous examples. Go to the “Adjusted Elevations and Error Propagation” section.
Here adjusted elevations, standard deviations and confidence regions are all shown
for all stations. Horizontal coordinates, even though entered for the benefit of
creating a plot diagram, are not shown as they play no part in the adjustment.

Elevations and Error Propagation (FeetUS)
Station Elev 3tdDev 95% Description
TIDAL1 1.3750 0.000000 0.000000 NGS Ref 1
TIDAL2 2.1650 0.000000 0.000000 NGS Ref 2
BM75 23.7680 0.000000 0.000000
BMZ6 57.1290 0.000000 0.000000 Brass Cap 1939
129 13.7299 0.007673 0.015040
125 39.6867 0.009283 0.018194 it Hyde
130 35.8643 0.009869 0.019343 Central
128 25.5307 D0.010857 0.0z20692
126 59.9463 0.010218 0.020026 :
127 44,4797 0.005107 0.017849 zﬂ

Go to the “Adjusted Observations and Residuals” section. Here the adjusted level
observations are shown along with their residuals. Note the standard errors used in
weighting the observations are all different because they are propagated based on the
length of the sections.

[ B LevNet.Ist

Adjusted Differential Level Chservations (FeetUS3)

From To Elev Diff Residual StdErr StdRes

TIDAL1 129 12.3549 0.0099 0.0117 0.8

BH75 129 -10.0381 -0.0151 0.0131 1.1

BH7S 125 15.9187 -0.0013 0.0146 0.1

129 130 22.1344 0.0044 0.0160 0.3

130 125 3.8224 -0.0106 0.0138 0.8

129 128 11.8008 -0.0092 0.0169 0.5

128 130 10.3336 -0.0024 0.0148 0.2

125 BM26 17.4423 -0.0157 0.0160 1.0

BM26 126 2.8173 0.0033 0.0163 0.2

130 126 24.0821 0.0171 0.0167 1.0

128 126 34.4156 -0.0064 0.0189 0.3

126 127 -15.4667 0.0183 0.0181 1.0

i28 127 18.9490 -0.0010 0.0176 0.1

TIDALZ 127 42.3147 -0.0063 0.0110 0.6 _j
A

This completes the “LevNet” example project, the last example in this tutorial.
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APPENDIX B - REFERENCES

The following list of reference materials is provided for STAR*NET users who wish to
study the practical and theoretical aspects of survey adjustments in more detail.

1. Wolf, Paul R., and Ghilani, Charles D., Adjustment Computations, Statistics and
Least Squares in Surveying and GIS, John Wiley & Sons, Inc., New York, 1997.

An excellent discussion of the theory of survey errors and the use of least squares
adjustments of survey networks. A valuable addition to your library.

2. Buckner, R.B., Surveying Measurements and Their Analysis, Landmark Enterprises,
Rancho Cordova, California, 1984.

An important reference text for the student and professional introducing the theory of
measurements, instrument use, propagation of errors in observations, and much more.
This easy-to-read book will develop your appreciation of measurements as an art and
a science, and it is highly recommended.

3. Anderson, J. M., and Mikhail, E.M., Introduction to Surveying, McGraw-Hill, New
York, 1985.

This text provides a good introduction to surveying practice. Mathematical concepts
are kept as simple as possible, but the book still treats them rigorously. Survey
adjustments and error propagation are not covered in depth.

4. Davis, R.E., Foote, F.S., Anderson, J.M, and Mikhail, EM., Surveying - Theory and
Practice, McGraw-Hill, New York, 1981.

The basic mathematical theory of STAR*NET is based on the appendices in this text,
although three-dimensional adjustment theory is not developed in the book. The text
provides a detailed and rigorous treatment of surveying and mapping. Several
chapters and appendices are devoted to survey adjustment, error propagation, and
statistical analysis. This book is recommended for those requiring an in-depth
theoretical and practical treatment of surveying and mapping.

5. Mikhail, EMM., and Gracie, G., Analysis and Adjustment of Survey Measurements,
Van Nostrand Reinhold Company, 1981.

This book introduces the basic concepts of obtaining and adjusting survey
measurements. It is systematic, rigorous, and practical in its approach. It covers the
basics of Least Squares Adjustment and statistical analysis, with many example
problems. It uses matrix algebra throughout, and is recommended for those
STAR*NET users requiring a solid introduction to survey adjustment.
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6. Mikhail, E.M., Observations and Least Squares, IEP, New York, 1976.

This text provides a complete development of Least Squares analysis techniques. It
concentrates on Least Squares Adjustments, error propagation, and statistical
analysis. It is theoretical in orientation, but does include some solved problems.

Richardus, P., Project Surveying, North-Holland Publishing Company, Amsterdam,
1966.

Yet another treatment of survey adjustments and optimization, with more of an
emphasis on engineering applications.

Krakiwsky, E.J, ed., Papers for the CISM Adjustment and Analysis Seminars,
Canadian Institute of Surveying and Mapping, Ottawa, 1987.

A useful collection of papers covering adjustment theory at an elementary and an
advanced level.

Press, W.H., Flannery, B.P., Teukolsky, S.A., and Vetterling, W.T., Numerical
Recipes - The Art of Scientific Computing, Cambridge University Press, Cambridge,
1986.

This work is a valuable reference book on the art of scientific computing. It contains
algorithms for matrix manipulations, statistical tests, eigenvector determination, etc.
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APPENDIX C - ADDITIONAL TECHNICAL INFORMATION

For reference, some general information and formulas used are listed here.

C.1 Program Limits

Limits for input data used in the program:

Number of stations in a network: 10,000

Length of an input data line: 500 Characters
Length of station names: 15

Length of station descriptors: 48

C.2 Error Messages and Warnings

Error and warning messages published by STAR*NET are designed to help you diagnose
errors detected in your data or problems found while adjusting. Most of these messages
are written to the “PROJECT.ERR” file where “PROJECT” is the name of your job. To
view the errors, select Output>Errors, or press the Errors tool button.

For level network adjustments, the type of data that you enter is very simple and
therefore most error or warning messages that may be reported will be easy to
understand. In addition, many error messages such as “Input Data File Does Not Exist” or
“Invalid File Name” are very generic in nature and need no explaination.

If you get an error or warning that you do not understand, please call or email technical
support at Starplus Software for assistance.
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